алибекalmaiurbrhje
03.08.2020 01:19

Составить программу с использованием цикла ДЛЯ ​


Составить программу с использованием цикла ДЛЯ ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pochta147369
01.12.2020 03:29
Линейный (последовательный) алгоритм — описание действий, которые выполняются однократно в заданном порядке. линейными являются алгоритмы отпирания дверей, заваривания чая, приготовления одного бутерброда. линейный алгоритм применяется при вычислении арифметического выражения, если в нем используются только действия сложения и вычитания.

например алгоритм заварки чая:

вскипятить воду ополоснуть кипятком заварной чайник засыпать в чайник заварку залить кипятком заварной чайник накрыть чайник специальной грелкой подождать до полного заваривания 5 минут
0,0(0 оценок)
Ответ:
Renton8546
06.10.2022 03:06
Const
  n = 15;

var
  a: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(61) - 30;
    Write(a[i]:4);
    if a[i]>0 then a[i]:=2*a[i]
    else
      if a[i]<0 then a[i]:=7
  end;
  Writeln;
  Writeln('После преобразования');
  for i := 1 to n do Write(a[i]:4);
  Writeln
end.

Тестовое решение:
Элементы массива
 -20  15  16  20   0  16 -15  -1  -2  21  -8 -10   4 -24   1
После преобразования
   7  30  32  40   0  32   7   7   7  42   7   7   8   7   2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота