Маргаритта357
02.12.2022 20:19

Дан массив a из n элементов. Скопировать в новый массив элементы массива а превышающие число k. Реализовать функцию для копирования этих элементов в отдельный массив.

Формат входных данных
0 < n < 100 - количество элементов массива

n элементов массива записанные через пробел. (0 < a[i] < 100)

0 < k < 100

Формат выходных данных
Вывести элементы массива превышающие k

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
TimurChik2100
23.04.2021 13:10

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

int N, k;

cin >> N;

vector<int> a(N, 0);

for (int i = 0; i < N; i++)

 cin >> a[i];

cin >> k;

for (int i = 0; i < N; i++)

 if (a[i] > k)

  cout << a[i] << " ";

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота