Dhgfhdudv
12.05.2020 20:11

Составить программу которая вычисляет сумму натуральных чисел от n до m кратных числу k (паскаль) ​​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
cross666
22.02.2023 12:40

Датчик сөзінің мәнін, түс датчигінің түс, дыбыс, жарық-сәуле, температура, жылдамдықты өлшейтінін біледі; Датчиктердің қызметіне қарай 4 түрге бөлінетінін анықтайды.

Роботтың тірі организм принциптеріне негізделіп жасалатын автоматты құрылғы екенін біледі. .

Оқушылардың басым бөлігі: Түс датчигіндегі жарық деңгейін анықтайтын 8 түрлі түстің кодын біледі. Негізгі оқу-жаттығу роботының атын біледі;

Кейбір оқушылар: Түс датчигінің екі түрге электронды және механикалық болып бөлінетінін, оның үш режимін: Түс режимін, Шағылысқан жарық жарықтылығы, Сыртқы жарық жарықтылығы режимдерін біледі. LEGO MINDSTORMS EDUCATION EV3 программасын аша алады. Программа мәзірінен Нұсқаулықпен (Инструкция) танысып, роботтың құрастырылуын біледі.

0,0(0 оценок)
Ответ:
taniaselikova
17.04.2021 17:57
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота