logan8
15.12.2022 04:15

Написать программу которая выводит на экран четные числа из интервала от 10 до 25 в Паскаль abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MigelAlemanValdes
30.08.2021 13:41
Program Project1;

var m:array [0..14] of integer; i:integer;

function IsPositive(a:integer):boolean;
begin
  result:=(a>-1);
end;

procedure work;
var min, max, count:integer;
begin
  count:=0;
  min:=m[0];
  max:=0;
  for i:=0 to 14 do begin
    if IsPositive(m[i]) then begin
      inc(count);
      if m[i]>max then max:=m[i];
      if m[i]<min then min:=m[i];
    end;
  end;
  writeln('MAX: ', max);
  writeln('MIN: ', min);
  writeln('Count: ', count);
end;

begin
  for i:=0 to 14 do begin
    write('n: ');
    readln(m[i]);
  end;

  work;

  readln;
end.
0,0(0 оценок)
Ответ:
Trasir
03.04.2020 05:44

Обратите внимание на то, что использование переменных c,k,j совершенно не нужно. Также в переменных

max,min лучше запоминать индексы, чтобы затем выполнить реверс.

const n = 10;

type mass = array[1..n] of integer;

var

a: mass;

i, max,min: integer;

begin

randomize;

for i := 1 to n do

A[i] := random(20)-10;

for i := 1 to n do

write(a[i]:3);

writeln();

// В переменных max и min будем запоминать

// ИНДЕКСЫ макс. и мин. элементов

max := 1;

min := 1;

for i := 1 to n do begin

if a[i] > a[max] then max := i;

if a[i] < a[min] then min := i;

end;

Writeln('A[',max,'] = ',a[max]);

Writeln('A[',min,'] = ',a[min]);

// Меняем местами max и min

i := a[max];

a[max]:=a[min];

a[min]:=i;

// Выводим результат на экран

for i := 1 to n do write(a[i]:3);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота