зара120
24.12.2020 01:04

Напишите программу, на вход которой подаётся прямоугольная матрица в виде последовательности строк. После последней строки матрицы идёт строка, содержащая только строку "end" (без кавычек). Программа должна вывести результат транспонирования исходной матрицы. Элементы строк выводить через пробел.

Sample Input:
3 2
1 4
end

Sample Output:
3 1
2 4

Программу написать в Python.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
milota5
20.03.2021 18:40

hi = 0

mas = []

while True:

   a = input()

   if a == 'end':

       break

   hi+=1

   mas.append([int(i) for i in a.split()])

for i in range(len(mas[0])):

   print(*[mas[g][i] for g in range(hi)])

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота