Анечка12311
27.01.2022 15:04

Python! Найдите все целые числа из промежутка от a до b, у которых сумма делителей равна k.

Формат входных данных
На вход подаются три натуральных числа — a, b и k, каждое на новой строке. Все числа не превосходят 1000 и выполняется условие a≤b.

Формат выходных данных
В единственной строке через пробел выведите все подходящие числа в порядке возрастания.


Python! Найдите все целые числа из промежутка от a до b, у которых сумма делителей равна k. Формат в

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olena4519
08.11.2021 09:53

Язык Python 3.7

Думаю по коду должно быть все понятно , но если возникнут вопросы

постараюсь ответить

1)  

x = int (input())  

print(6*x*(x+2)-(x+4))

2)

x = int (input())

if x>0:  

   print((x**2)+(2*x))

else :    

   print(x-3)

3)

x=13

i=10 #Счетчик

while i<100:               #Цикл будет выполнятся пока i меньше 100

   print(x*i)

   i=i+1                        #Обновление счетчика

4)

x=0                               #Создание счетчика

while x<21:  

   print(9*(x**2)+6*x)

   x=x+2                      #Обновление счетчика

5)

x1=int(input())

x2=int(input())

x3=int(input())

if x1==x2 and x2==x3:

   print("Треугольник равносторонний")

else:

   print("Треугольник не равносторонний")

6)

a=int(input())                   # Ввод значения

for i in range (1,a+1):       #Создание цикла , в котором перебираются                      

      print(i**2)                   числа   от 1 до a                      

   

0,0(0 оценок)
Ответ:
МарсСМарса
29.05.2023 07:00

Семейство маковых - Papaueraceae


Однолетнее травянистое растение до 100 - 120см высоты с крупными одиночными цветками, лепестки белого цвета с фиолетовым глазком. Стебель прямой. Листья крупные, яйцевидные. Плод - шаровидная или овально - продолговатая коробочка с семенами. Цветет в июне - августе, плоды созревают в августе - сентябре.


Размножаются семенами.

 


Используют в медицине зрелые(сухие) коробочки со стеблем до 40 см, собираемые в период созревания семян. Из мака приготавливают обезболивающие препараты и антиспазматическое средство.

 


Мак выращивается в СССР в Казахстане, Киргизии, на Украине и в Поволжье.

 


Маки представлены однолетними, двулетними и многолетними растениями. Зимостойкие, светолюбивые, они предпочитают легкие богатые гумусом почвы, содержащие известь. Цветут 2–3 дня. Однолетние маки, срезанные с чуть треснувшими бутонами и сразу опущенные в воду, цветут дольше, чем в грунте. Маки можно пересаживать; размножают семенами.

Наиболее распростаренные виды маков: мак полевой мак голубой мак голостебельный (сибирский) мак восточный и прицветковый


Мак полевой (самосейка) – растение однолетнее. За блестящие лепестки его называют также “шелковым маком”. Цветет с конца мая до осени.

 

Семена очень мелкие, поэтому их лучше предварительно намочить и смешать с песком в соотношении 1:10. Сажать гнездовым всходы прореживать. Чтобы продлить сроки цветения, можно сеять несколько раз в течение сезона с интервалами 20–30 дней.

 

Мак голубой – двулетнее растение, можно использовать как однолетник. Семена высевают в грунт весной, всходы прореживают.

 

 

Мак голостебельный, или сибирский – многолетнее растение, используется и как двулетник. Цветет с мая по сентябрь. Семена высаживают весной или в августе. При подзимнем посеве зацветает в мае следующего года.

 

 

Маки восточный и прицветковый – многолетние неприхотливые морозостойкие растения. Хорошо растут на открытом месте, легко переносят небольшое затемнение, но при переувлажнении могут загнивать корни.

 

 

Оба вида размножаются семенами, корневыми и зелеными черенками. Посев производят рано весной в парники или теплицы, пикируют в фазе 1–2-х настоящих листьев и сразу высаживают на постоянное место. На черенки используют боковые слабые побеги, которые осторожно срезают и высаживают на затененные, влажные гряды. Лучшее время пересадки – середина лета или 2-я половина августа.

 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота