17Yana20031
15.04.2022 05:18

написать программу на с++: Напишіть програму, яка зчитує два цілих числа a і b (від 1 до 1000) та виводить найбільше значення з них. Вхідні дані:

12
3
Вихідні дані:

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
oleshckewitchd
27.02.2023 21:59

Здравствуйте ! Вы не указали, каким образом должен заполняться массив (рандомом или с клавиатуры), поэтому я решила заполнить его рандомными числами. При необходимости можете изменить интервал.

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   int sum = 0;

   const int rows = 8;

   const int cols = 8;

   int arr[rows][cols];

   setlocale(LC_ALL, "Russian");

   for (int i = 0; i < rows; i++)

   {

       for (int j = 0; j < cols; j++)

       {

           arr[i][j] = rand() % 10;

           cout << arr[i][j] << " ";

       }

       cout << endl;

   }

   cout << endl << endl;

   for (int i = 0; i < rows; i++)

   {

       for (int j = 0; j < cols; j++)

           sum = arr[i][j] + sum;

   }

   cout << "Сумма элементов массива: " << sum << endl;

   cout << endl;

   for (int i = 0; i < rows; i++)

   {

       for (int j = 0; j < cols; j++)

       {

           if (j == 0)

               arr[i][j] = arr[i][j] / sum;

           cout << " " << arr[i][j];

       }

       cout << endl;

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
Алижан025
07.12.2020 15:41

Объяснение:

1)

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "RUSSIAN");    

int a, b, c, w, h;

cout << "Введите ширину дверного проема, см: "; cin >> w;

cout << "Введите высоту дверного проема, см: "; cin >> h;

cout << endl;

cout << "Введите высоту шкафа, см: "; cin >> a;

cout << "Введите ширину шкафа, см: "; cin >> b;

cout << "Введите глубину шкафа, см: "; cin >> c;

cout << endl<< "Результат: ";

if (b < w && a < h || c < w && a < h || c < w && b < h) cout << "Шкаф пройдет в дверной проем." << endl;

else cout << "Шкаф не пройдет в дверной проем." << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота