kimhakip09577
28.02.2023 20:40

Написать программу, которая в зависимости от температуры предлагает, что надеть плз)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
7fan7
09.03.2023 01:10
сукупність характерних ознак, особливостей, властивих чому-небудь (наприклад, строгого стилю меблі);

У вужчому значенні — сукупність характерних рис літератури або мистецтва тієї чи іншої епохи або науки, а також сукупність ознак, які характеризують мистецтво певного народу, країни (голландський, російський, український стиль; східний, західний стиль).

Посилання (англ. reference), також поклик — посилання у паперових і електронних документах — уривок, витяг з якого-небудь твору, на який посилаються у викладі, з точною назвою джерела й вказівкою на відповідну сторінку. Іноді те саме, що виноска[1]. Останнім часом паралельно почали вживати термін — покликання.[2]

икористанням відповідних стилів заголовків, то текстовий процесор Word 2007дає змогу автоматично створити зміст такого документа. Для цього програма здійснює посторінковий поділ документа і для кожного структурного елемента документа визначає номер сторінки, з якої ця частина документа розпочинається. Отримані дані оформлюються у вигляді таблиці, у яку вносяться назви заголовків і відповідні номери сторінок.3. Вибрати в списку вбудованих зразків потрібний варіант оформлення змісту Створений зміст можна використовувати для швидкого переміщення до потрібних структурних частин документа, пошуку необхідних розділів, підрозділів тощо. Для цього слід у змісті документа вибрати потрібний заголовок, тримаючи натиснутою клавішу Ctrl.

0,0(0 оценок)
Ответ:
rutasolntseva
15.08.2022 15:18

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота