tatsux2010
10.01.2022 02:33

С++ Шахматная доска
Даны два числа n и m. Создайте двумерный массив размером n×m и заполните его символами 1 и 0 в шахматном порядке. В левом верхнем углу должна стоять единица.

Входные данные

Дано два наутральных числа n и m, не прывышающие 10.

Выходные данные

Выведите заполнение доски.

Примеры
Ввод
Вывод
3 4
1 0 1 0
0 1 0 1
1 0 1 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elena407
18.04.2021 15:54

#include <iostream>

#include <vector>

using namespace std;

signed main(){

   int n, m;

   cin >> n >> m;

   vector<vector<int>> a(n, vector<int> (m));

   for(int i = 0; i < n; i++)

       for(int j = 0; j < m; j++)

           !((i+j) & 1) ? a[i][j] = 1 : a[i][j] = 0;

   for(int i = 0; i < n; i++){

       for(int j = 0; j < m; j++)

           cout << a[i][j] << " ";

       cout << "\n";

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота