CISA9999
18.01.2020 00:03

XOR У вас есть массив чисел длиною "N". Нужно найти XOR всех чисел.

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Выведите XOR всех чисел

Пример 1
Ввод:
10
71 39 83 41 67 55 89 5 45 77

Вывод:
82

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Islikzaziy
26.09.2020 22:18
Const
  n = 10;

var
  a: array[0..10] of integer;
  i, s: integer;

begin

//Заполнение массива сл. числами

  for i := 1 to n do
  begin
    a[i] := random(201) - 100;
    write(a[i]:4);
  end;
  writeln;

//1) Все элементы не превышающие число 100

  writeln('Не больше 100 ');
  for i := 1 to n do
    if a[i] <= 100 then
      write( a[i]:4);
  writeln;

// 2) Все четные элементы

  writeln('Кратные двум ');
  for i := 1 to n do
    if a[i] mod 2 = 0 then  
      write( a[i]:4);
  writeln;

// 3) Все элементы, являющиеся трехзначными числами

   writeln('Трехзначные ');
  for i := 1 to n do
    if (a[i] < -99) or (a[i] > 99) then  
      write(a[i]:4);
  writeln;

// 4) Третий, шестой и т.д элементы.

  i := 3;
  writeln(' номера 3, 6, 9 и  т.д.');
  while i < n do
  begin
    write(a[i]:4);
    i := i + 3;
  end;
end.
0,0(0 оценок)
Ответ:
hghfYES
19.08.2020 10:30
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var a:=MatrixRandom(7,7,0,9);
  var k:=0;
  for var i:=0 to 6 do begin
    for var j:=0 to 6 do begin
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Тестовое решение:
  2  1  7  3  3  2  7
  9  2  9  2  0  5  5
  4  2  6  9  4  6  0
  1  0  3  5  4  5  9
  6  3  6  0  2  0  8
  0  8  4  3  2  1  8
  6  0  4  4  5  4  0
Кол-во элементов на [1,5]: 27

Вариант "совсем для школы"

const
  n=7;
var
  a:array[1..n,1..n] of integer;
  i,j,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(10);
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота