zarasabaka
29.09.2022 14:59

надо очень Напишите программу, которая вычисляет значение функции у и выводит его на экран. Значение переменной x вводится с клавиатуры. =24 − 5+,если х<10 = 52−,если 10 <=<13 =73−5,если >=13

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Математик094
03.01.2022 12:16

#include <iostream>

#include <cmath>

#include <vector>

using namespace std;

int main() {

vector<float> coordinates;

string a;

getline(cin, a);

string buffer;

for(int i = 0; i<a.length(); ++i) {

 if(a[i]!=' ') {

  buffer+=a[i];

 } if(a[i]==' '||i==a.length()-1) {

  if(buffer[buffer.length()-1]=='.') {

   buffer+="0";

  }  

  float num = stof(buffer);

  coordinates.push_back(num);

  buffer = "";

 }

}

if(coordinates.size()!=4) {

 cout << "wrong data. example: 1.1 2.2 3.3 4.4";

}

float result;

int temp1, temp2, temp3, temp4;

temp1 = coordinates[0]-coordinates[2];

temp2 = coordinates[1]-coordinates[3];

temp1 = temp1 * temp1;

temp2 = temp2 * temp2;

temp3 = temp1 + temp2;

result = sqrt(temp3);

cout << result;

}

0,0(0 оценок)
Ответ:
Яся00000
19.01.2022 11:14

Компьютер - это устройство, которое выполняет набор инструкций в цифровом виде или через двоичный формат, который позволяет получить информацию от периферийных устройств и вывода в формате,который пользователь может понять. Компьютеры обрабатывают информацию через двоичный формат, который состоит только из 0 и 1 , который основан на транзисторной технологии, в которой один микропроцессор может хранить до триллиона транзисторов для обработки информации. Так как компьютеры считаются устройствами, они могут быть использованы для автоматизации таких задач, как распределение денежных средств через Банкоматы, командовать роботами на конвейере, или даже распределение вселенной.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота