Maryana1069
03.11.2021 05:33

Дан одпомертын массив A(N) Составить программу.Все элементы, стоя не ни четных местах и предшествуващие первому по порядку максимуму, умножить на минимум.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mashalove16
07.08.2021 01:58
Var s:string;
n,k,i:integer;
begin
for n:=1 to 2 do
 begin
 writeln('Введите строку ',n,':');
 readln(s);
 k:=0;
 for i:=1 to length(s) do
  begin
  case s[i] of
   '[': k:=k+1;
   ']': k:=k-1;
   end;
  end;
 if k=0 
 then writeln('В строке ',s,' количество [ и ] одинаково')
 else writeln('В строке ',s,' количество [ и ] не одинаково');
 end;
end.

Пример:
Введите строку 1:
c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c
В строке c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c количество [ и ] одинаково
Введите строку 2:
Просто [ пример ]] со [[ скобками
В строке Просто [ пример ]] со [[ скобками количество [ и ] не одинаково
0,0(0 оценок)
Ответ:
vomid5421
21.11.2020 15:44
1. program primer; //имя программы вроде(необязательно)
var a: array [1..10] of integer; //Объявление целочисленного массива а размером 10 эл.
i, s: integer; //Объявление двух целочисленных переменных
begin //начало
randomize; //Включает датчик случайных чисел(в PascalABC.NET можно не писать)
for i:= 1 to 10 do //Запускается цикл от 1 до 10
a[i]:=random(15-5+1)+5; //Текущему элементу присваивается случайное значение от 5 до 15. И так до тех пор, пока не закончится цикл, т.е. через 10 шагов
for i:= 1 to 10 do //Запускается цикл от 1 до 10
write (a[i], ' '); //Выводится текущий элемент массива. И так до тех пор, пока не закончится цикл, т.е. через 10 шагов
s:=0; //Переменной для суммы присваивается 0
for i:= 1 to 10 do //Запускается цикл от 1 до 10
if a[i] mod 3=0 then //Если текущий элемент массива делится на 3 без остатка тогда
s := s + a[i]; //к сумме прибавляется текущий элемент массива
write('сумма = ',s); //вывод сообщения и значение переменной s
end. //конец

2. Дан массив 16 1 8 2 4 4
к=0
со 2 по 6 делаем
если A[i-1] >=A[i] , делаем к=к+1
1 итерация: если A1>=A2 (A1=16, A2=1, 16>1, значит к=к+1 = 1)
2 итерация: если A2>=A3 (A2=1, A3=8, 1>8? нет, значит к остается прежним)
3 итерация: 8>2? да к=2
4 итерация: 2>4? нет к=2
5: 4>=4? да к=3
выводим к=3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота