Anna282005u
12.09.2020 10:33

Написать программу в питоне
(написала половину программы, а дальше хз что делать)


Написать программу в питоне (написала половину программы, а дальше хз что делать)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Seregabludov98
01.06.2022 19:41
1)
var
    s: string[6];
    n: integer;

begin
    s := 'отлично';
    n := length(s);
    writeln(length('отлично'));
    writeln(n);
end.

Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6

2) рисунок

3)var
    s, s1: string;
    n: integer;

begin
    s := 'информатика';
    s1 := copy(s, 3, 5);
    n := pos(s, s1);
    writeln('s=', s);
    writeln('s1=', s1);
    writeln('n=', n);
end.

Вывод
s=информатика
s1=форма
n=0

Все верно, в s1 не содержится s, а наоборот

Садекватным объяснением! 1) дан фрагмент программы: var s: string[6]; n: integer; begin s: ='отлично
0,0(0 оценок)
Ответ:
anka110
04.09.2021 08:42
Var
    i, n, s: integer;

begin
    readln(n);
    i := 0;
    s := 0;
    
    while i < 7 do
    begin
        if (n mod 2 = 1) then begin
            s := s + n;
            i := i + 1;
        end;
        n := n + 1;
    end;
    
    writeln(s);
end.

var
    i, n, s: integer;

begin
    readln(n);
    i := 0;
    s := 0;
    
    repeat
        if (n mod 2 = 1) then begin
            s := s + n;
            i := i + 1;
        end;
        n := n + 1;
    until i >= 7;
    
    writeln(s);
end.

var
    i, n, s: integer;

begin
    readln(n);
    n := n + (n + 1) mod 2;
    s := 0;
    
    for i := 1 to 7 do
    begin
        s := s + n;
        writeln(n);
        n := n + 2;
    end;
    
    writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота