напишите программу вывода на экран всех дней января прогнозный ращмер осадков в которые не превысит значение 9.размер осадков определить случайным образом
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016 begin var n:=ReadInteger('Кол-во элементов:'); var a:=ArrRandomReal(n,-10,20); a.Println; Writeln('С округлением если |x|<1'); for var i:=0 to n-1 do if abs(a[i])<1 then a[i]:=Round(a[i]); a.Println end.
Для того, чтобы узнать в каком подъезде находится квартира, разделим ее номер на количество квартир в подъезде, на 36. Запомним частное и остаток от деления. Пусть, к примеру, нам дана квартира 85. Делим на 36. Получаем частное 2 и в остатке 13. 2 - это номер подъезда. Теперь разделим 13 на 4 (число квартир на этаже), запомним частное и остаток. В результате получим 3 и остаток 1. Значит, наша квартира на 3-м этаже, и если номера квартир идут слева направо, то квартира будет крайняя слева.
Итак, квартира с номером 85 находится во втором подъезде, на 3-м этаже нашего дома.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку