marta62
01.05.2020 10:19

Пользователь вводит 2 числа. Вам необходимо написать программу, которая будет считать разницу между этими числами (разница обязательно должна быть положительной) и выводить в консоль. Заранее неизвестно, какое из чисел больше, первое или второе. Пример входных данных:

3

5

Пример выходных данных:

2

1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
moldabaevamaria
29.04.2021 18:43
#include <stdio.h>

#define maxsize 105

typedef struct station{
    int x, y, z;
} station;

int abs(int x){
    return x >= 0 ? x : -x;
}

int min(int a, int b){
    return a <= b ? a : b;
}

int main(){
    FILE *ist, *ost;
    
    station s[maxsize];
    int w[maxsize][maxsize];
    int inc[maxsize];
    int n,i,j,k,m,l,r;
    
    ist = fopen("input.txt","r");
    
    fscanf(ist, "%d", &n);
    for(i = 0; i < n; i++) fscanf(ist, "%d %d %d", &s[i].x, &s[i].y, &s[i].z);
    
    fclose(ist);
    
    for(i = 0; i < n; i++) inc[i] = 0;
    
    for(i = 0; i < n; i++)
    for(j = i; j < n; j++)
        w[i][j] = w[j][i] = min(abs(s[i].x - s[j].x), min(abs(s[i].y - s[j].y), abs(s[i].z - s[j].z)) );
    
    r = 0; k = 1;
    inc[0] = 1;
    while(k < n){
        m = -1;
        for(i = 0; i < n; i++) if(inc[i])
        for(j = 0; j < n; j++) if(!inc[j])
            if (m == -1 || w[i][j] < m) m = w[i][j], l = j;
        r += m;
        inc[l] = 1;
        k++;
    }
    
    ost = fopen("output.txt","w");
    fprintf(ost,"%d", r);
    fclose(ost);
    
    return 0;
}
0,0(0 оценок)
Ответ:
qwerty06151
12.03.2022 10:55
13 сентября 1956 года, то есть более полвека назад компания IBM представила свой первый накопитель на жестких магнитных дисках (позднее данные устройства получили полуофициальное прозвище «винчестер») . 
И это изобретение со временем фактически создало огромную индустрию магнитных накопителей, без которых сейчас немыслимо ни одно мало-мальски мощное вычислительное устройство, поскольку подавляющее большинство информации, которыми оперируют эти самые вычислительные устройства, хранится именно на магнитных носителях. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота