Ksenon102
23.12.2022 08:03

Даны целые числа a, b, c и d. Составьте программу вычисления произведения последних цифр суммы чисел a и b и разности чисел c и d. ЯЗЫК PYTHON

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
valiente
10.02.2021 03:05
{int a=1; while (a<9) a=a+1; cout<<a<<endl;} В цикл подается переменная a=1. В цикле с каждым шагом значение переменной a увеличивается на 1. Цикл длится, пока a<9. Последовательные значения переменной: 1, 2, 3, 4, 5, 6, 7, 8, 9. 9 не меньше 9, поэтому цикл завершается. На экран выводится 9. A) {int a=1; for(; a<10; ++a); cout<<a<<endl;} В цикл подается переменная a=1. В цикле с каждым шагом значение переменной a увеличивается на 1. Цикл длится, пока a<10, при этом сначала производится увеличение значения переменной, и лишь потом проверка. Последовательные значения переменной: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10. 10 не меньше 10, поэтому цикл завершается. На экран выводится 10. Б) {int a=1; for(int a=1; a<9; a++); cout<<a<<endl;} Вне цикла объявляется переменная а=1. Внутри цикла объявляется новая локальная переменная a=1, и с каждым шагом значение этой переменной увеличивается на 1. При этом при завершении цикла локальная переменная не возвращается в тело функции, поэтому на экран выводится значение первой переменной а, равное 1. В) {int a=1; for(; a<9; a=a+1); cout<<a<<endl;} В цикл подается переменная a=1. В цикле с каждым шагом значение переменной a увеличивается на 1. Цикл длится, пока a<9. Последовательные значения переменной: 1, 2, 3, 4, 5, 6, 7, 8, 9. 9 не меньше 9, поэтому цикл завершается. На экран выводится 9. Г) {int a=1; for(int a=1; a<=9; a=a+1); cout<<a;} Вне цикла объявляется переменная а=1. Внутри цикла объявляется новая локальная переменная a=1, и с каждым шагом значение этой переменной увеличивается на 1. При этом при завершении цикла локальная переменная не возвращается в тело функции, поэтому на экран выводится значение первой переменной а, равное 1.

Искомый фрагмент - В)

0,0(0 оценок)
Ответ:
Asil1231
14.04.2023 07:36

Window-95:


32-разрядность означает, что операции над 32-разрядными данными здесь выполняются заметно быстрее, чем в 16-разрядных ОС, поскольку в них требуется программная реализация над 32-разрядными данными. Под управлением Windows 95 могут выполняться н 16-разрядные приложения.


Многозадачность предоставляет возможность одновременной (параллельной) работы с несколькими приложениями. Это повышает эффективность использования микропроцессора и производительность труда пользователя.


Мпогопоточностъозначает организовывать одновременную обработку нескольких потоков, конкурирующих за процессорное время. При этом допускается параллельное выполнение нескольких приложений, а также нескольких фрагментов (подзадач) одного или нескольких приложений. Например, в текстовом процессоре могут одновременно выполняться автоматическая проверка орфографии и редактирование документа.


Пользовательский интерфейсWindows 95 обеспечивает удобства в запуске и переключении приложений. Основными компонентами пользовательского интерфейса являются рабочий стол (содержит ярлычки) п панель задач (обеспечивает запуск и переключение приложении). На рабочем столе размещены графические объекты, соответствующие приложениям, документам, сетевым устройствам. Каждый графический объект имеет поименованный ярлычок. С мыши, ярлычков, главного меню и панели задач пользователь может легко запускать и переключать приложения.


ТехнологияPlugandPlay (включи и работай) ориентирована на поддержку любо­го типа устройств, включая мониторы, видеоплаты, принтеры, звуковые карты, модемы, приводы CD-ROM, контроллеры магнитных дисков. При ее использовании обеспечиваются следующие вс функции: распознавание устройств для установки и настройки, динамическое изменение состояния системы, интеграция драйверов устройств, системных компонентов и пользовательского интерфейса. При подключении устройств Windows 95 самостоятельно выясняет используемые номера прерываний, адреса портов ввода-вывода, каналы прямого доступа к памяти. При возникновении кон­фликтов они разрешаются автоматически, избавляя пользователя от необходимости поиска подходящих параметров для совместно подключаемых устройств.


Windows XP:


По статистике, меньше «глючит» и тормозит. Это одна из причин, почему офисные предприятия предпочитают эту ОС: она лучше 7 по количеству системных сбоев;


Имеет приятный интерфейс, лишённый ненужных элементов;


Обладает улучшенной системой защиты: приложения и драйверы не могут повредить важным файлам ядра системы. Последние доступны только в режиме чтения;


Предотвращает типичные неполадки системы, встречающиеся в ранних версиях windows; в случае перезаписи системных файлов xp сама восстанавливает нужную версию;


Лучше 7 по памяти: занимает примерно в 3 раза меньше;


При работе нескольких приложений система быстро реагирует на команды, а её работа стабильна и практически исключает вылеты и перезапуски;


Поддерживает оперативную память до 4 Гб и двух микропроцессоров;


Использует EFS – особая шифровка файлов. Каждый из них получает шифр, генерируемый рандомно, что снижает возможность успешных хакерских атак;


Обеспечивает сохранность и безопасность файлов, передаваемых по частным виртуальным сетям;


Поддерживает смарт-карты, дополняющие некоторые программные решения (интерактивная регистрация, служба идентификации клиентов и д.);


Использует проигрыватель Windows Media™, первое приложение, объединившее в себе все возможности работы с мультимедийными файлами;


Имеет встроенное средство для записи компакт-дисков;


Допускает возможности работы на нескольких экранах, производительность труда возрастает;


Возможность доступа к сетевым документам без подключения к сети;


Возможность просмотра веб-страниц без подключения интернета;


Переносной компьютер можно состыковывать и отстыковывать без перезагрузки системы;


Восстановление системы до последнего рабочего состояния без потери пользовательских файлов (это свойственно и 7).


Windows 7:


Возможность осуществить даунгрейд до XP. В основном этой функцией пользуются офисы, так как старая версия windows для подобной работы лучше. Восстановление доступно до 2020 года;


Спорное достоинство: интерфейс. Многие считают, что у 7 он на порядок лучше (имеются в виду эффекты Aero: анимация и прозрачность окон);


Многочисленные утилиты быстрому пользованию необходимыми функциями. Включить wi-fi вы сможете тремя щелчками мыши;


При нехватке оперативной памяти есть возможность подкачки с USB-накопителя. В xp подкачка возможна только с жёсткого диска;


С точки зрения геймеров, наиболее важным преимуществом является поддержка DirectX 10 и 11 (xp поддерживает 9);


Практически любое стороннее устройство будет автоматически определено системой (фотоаппарат, телефон и проч.) без необходимости поиска и установки драйвера;


Возможность сенсорного управления;


Обновление до windows 8 осуществляется одним нажатием мыши.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота