Пташник
11.01.2022 07:33

Составьте программу формирования из массива А(07) двух массивов, в которых первый массив залолнеи элементами кратилми 1, а второй - четалси элементами. Вывести старый и новый массивы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gusein123
28.04.2020 23:07
Namespace:   System.Windows.Forms
MessageBox
public static DialogResult Show( string text ) - только сам текст сообщения
Например
MessageBox.Show("Hello, world.");

Есть много перегрузок у метода Show
Show(String, String) - текст и заголовок
Show(String, String, MessageBoxButtons) - текст и заголовок и кнопки
Show(String, String, MessageBoxButtons, MessageBoxIcon) - плюс иконка окна сообщения
Show(String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) - плюс выбрана кнопка по умолчанию
И еще и еще. Смотрите справку на сайте MSDN

Пример с иконкой
MessageBox.Show("Typical installation is strongly recommended.", "Install information", MessageBoxButtons.OK, MessageBoxIcon.Information);
0,0(0 оценок)
Ответ:
Горова2007
28.03.2022 05:00

Объяснение:

a - массив;

sum - сумма элементов массива;

avrg - среднее значение.

Пример алгоритма решения задачи:

Заполняем массив (например, случайными числами).

Переменной sum изначально присваиваем значение 0.

Вычисляем сумму элементов, в цикле перебирая массив и добавляя значение каждого к переменной sum.

Находим среднее арифметическое, путем деления суммы на количество элементов (хранится в константе N).

Выводим на экран весь массив и найденное среднее значение. (Это не обязательно, но необходимо для удобства.)

Снова в цикле перебираем массив. Если очередной элемент больше среднего арифметического, то выводим этот элемент на экран.

const N = 10;

var

a: array[1..N] of integer;

i: byte;

avrg: real;

sum: integer;

begin

randomize;

for i:=1 to N do a[i]:=random(50)+1;

sum := 0;

for i:=1 to N do sum := sum + a[i];

avrg := sum/N;

// весь массив

for i:=1 to N do write(a[i]:3);

writeln;

writeln('Среднее арифм.: ',avrg:4:2

for i:=1 to N do if a[i]>avrg then write(a[i]:3);

writeln;

end.

Пример выполнения программы:

7 36 21 48 33 46 7 17 19 41

Среднее арифм.: 27.50

36 48 33 46 41

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота