anton297
16.10.2020 22:57

С++ Удаление элемента
Удалите из массива элемент в индексом k. Обратите внимание, считывание и вывод массива уже написаны за вас, необходимо написать только фрагмент программы — само удаление элемента.

Входные данные

В первой строке задано натруальное число n (n≤100) и индекс k (0≤k
#include
using namespace std;
int main()
{
int n, k;
cin >> n >> k;
vector A(n);
for (int i = 0; i < A.size(); i++) {
cin >> A[i];
}

for (int i = 0; i < A.size(); ++i){
cout << A[i] << " ";
}
cout << endl;
return 0;
}

между строками кода надо дописать код

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
asqbwez
13.08.2021 13:52
ответ: 9504 

var steps := 12; // За кол-во ходов
var Xend  := 6; // В точку с координатой X
var Yend  := 4; // ... и Y

var vars := 0; procedure Find(step, X, Y : Integer);

begin 
    if step = 0 then   
        vars += (X = Xend) and (Y = Yend) ? 1 : 0
    else   
        begin     
             Find(step - 1, X + 1, Y    );     
             Find(step - 1, X - 1, Y    );     
             Find(step - 1, X    , Y + 1);     
             Find(step - 1, X    , Y - 1);   
        end;
end; 
begin 
     Find(steps, 0, 0); 
     Print(vars);
end.
0,0(0 оценок)
Ответ:
0202991
13.08.2021 13:52
ответ: 5940

var steps := 12; // За кол-во ходов
var Xend  := 7; // В точку с координатой X
var Yend  := 3; // ... и Y

var vars := 0; procedure Find(step, X, Y : Integer);

begin  
    if step = 0 then    
        vars += (X = Xend) and (Y = Yend) ? 1 : 0
    else    
        begin      
             Find(step - 1, X + 1, Y    );      
             Find(step - 1, X - 1, Y    );      
             Find(step - 1, X    , Y + 1);      
             Find(step - 1, X    , Y - 1);    
        end;
end; 
begin  
     Find(steps, 0, 0);  
     Print(vars);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота