dimsa97
09.03.2021 03:36

с информатикой 1.
Найти количество чисел в массиве, которые делятся на 3, но не делятся на 7.

2.
Найдите сумму чисел массива, которые расположены до первого четного числа массива. Если четных чисел в массиве нет, то найти сумму всех чисел за исключением крайних.

3.
Среди элементов с нечетными номерами найдите наибольший элемент массива, который делится на 3.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LizaMelehina457
18.05.2021 05:31
1)program fagasg;
var x1,y1,r: real;
begin
Writeln('Введите х1');
readln(x1);
Writeln('Введите у1');
readln(y1);
r:=sqrt(x1*x1+y1*y1);
Writeln('Расстояние от х1 до у1=',r);
end.
2)Program fsgasghfd;
var c,s: real;   
a,b: integer;
begin
Writeln('Введите первое целое число');
readln(a);
Writeln('Введите второе целое число');
readln(b);
Writeln('Введите дробное число');
readln(c);
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then 
s:=a+b+c
else writeln('Знаки разные');
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then Writeln('Сумма чисел:',s);
end.
3)Program wrqrwqr;
var A: Array[1..100] of integer;   
B: Array[1..100] of integer;   
C: Array[1..100] of integer;   
s,i,h,g: integer;
begin
h:=0;
g:=0;
Writeln('введите размерность массива');
readln(s);
Writeln('Вводится первый массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(A[i]); 
end;
Writeln('Вводится второй массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(B[i]); 
end;
For i:=1 to s do  begin   
If A[i]>B[i] then C[i]:=A[i]     
else C[i]:=B[i];   
If C[i] mod 2=1 then h:=h+1;   
If C[i] mod 2=0 then g:=g+1; 
end; 
Writeln('Количество нечётных элементов в массиве:',h); 
Writeln('Количество чётных элементов в массиве:',g);
end.
0,0(0 оценок)
Ответ:
grizzly15
11.05.2022 02:38

1)36(10)=>(..)(8) Из 10 ой системы в любую другую мы переводим методом деления и остатки записываем в ответ

а)36/8=4 и 4 в остатке ответ 44(8)

б) следуя из задания а тут у нас отрицательное число следовательно будет -44(8)

в)106(10)=>(..)(8)

106/8=13 и 2 в остатке

13/2=1 и 5 в остатке ответ: 152(8)

г) -152(8)

2)a)00010100(2)=>(..)(10) Здесь мы работаем методом коэкоэфициентов

0*2^7+0*2^6+0*2^5+1*2^4+0*2^3+1*2^2+0*2^1+0*2^0=20(10)

ответ:20

б)11110110(2)=>(..)(10)

1*2^7+1*2^6+1*2^5+1*2^4+0*2^3+1*2^2+1*2^1+0*2^0=246(10)

ответ:246(

в) 00011100(2)=>(..)(10)

0*2^7+0*2^6+0*2^5+1*2^4+1*2^3+1*2^2+0*2^1+0*2^0=28(10)

ответ: 28

г) 10101100(2)=>(..)(10)

1*2^7+0*2^6+1*2^5+0*2^4+1*2^3+1*2^2+0*2^1+0*2^0=86(10)

ответ: 86

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота