Kazybek2005
24.07.2021 19:10

Игра в "Жизнь" Необходимо написать программу(язык не важен).
На входе нам даётся количество повторений, а также матрица 5*5 нулей и единиц.
В случае, если около единицы ноль(сверху, слева, справа и снизу), он меняется на один.
Если же наоборот около единицы один, то она меняется на ноль.
На вывод должна пойти матрица, после n-ых повторений.

Пример 1:
Ввод:
1
00000
00000
00100
00000
00000
Вывод:
00000
00100
01110
00100

Пример 2:
Ввод:
2
00000
00000
00100
00000
00000
Вывод:
00100
01010
10001
01010
00100

Удачи(в инете искать смысла нет)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Даниил5356
06.03.2020 05:30
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4
0,0(0 оценок)
Ответ:
KrazyKot
22.05.2022 12:36

Відповідь:

import random

def printer(matr):

   for l in matr:

       print(*l,sep = "\t")

n = int(input("Введите порядок матрицы:\n"))

k = int(input("Введите строку для поиска её минимума:\n"))

matrix = []

for i in range(n):

   t=[]

   for j in range(n):

       t.append(random.randint(0,100))

   matrix.append(t)

print("Исходная матрица:\n")

printer(matrix)

k_min = min(matrix[k-1])

print(f"Минимальный элемент строки {k} равен {k_min}\n")

for i in range(n):

   for j in range(n):

       print(f"Элемент [{i+1},{j+1}]: {k_min}*{matrix[i][j]} = {matrix[i][j]*k_min}")

       matrix[i][j]*=k_min

print("Окончательная матрица:\n")

printer(matrix)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота