сергоо16
16.08.2022 10:04

Сижу уже какой час не могу решить! 98 кто напишет программы написать программу в паскале, выводящую на экран информацию по заданному образцу: №1 100000000 120000000 123000000 123400000 123450000 123456000 123456700 123456780 123456789 №2 111111111 100000001 100000001 100000001 100000001 100000001 100000001 100000001 111111111 №3 100000000 020000000 003000000 000400000 000050000 000006000 000000700 000000080 000000009

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Катядонецк
09.06.2020 22:57
Function prime(x:integer):boolean;
var
 t:boolean;
 d:integer;
begin
 t := true;
 d := 2;
 while t and (d*d <= x) do
   begin
   if x mod d = 0 then 
     t := false;
   d := d + 1
   end;
 prime := t
end;

function order(x:integer):boolean;
var
 t:boolean;
 d:integer;
begin
 d := -1;
 repeat
   t := x mod 10 > d;
   d := x mod 10;
   x := x div 10
 until not t or (x = 0);
 order := t
end;

var
 t:boolean;
 i,k,n:integer;
begin
 t := false;
 read(k,n);
 for i := k to n do
   if prime(i) then
   if order(i) then
     begin
     write(i,' ');
     t := true
     end;
 if not t then
   write(0)
end.
0,0(0 оценок)
Ответ:
sek071001p0ancj
06.09.2022 05:31
Class ArrayMultiplication{
 public static void main(String args[]){
  String fileName = "Array.txt", aNum = ""; int nArray[] = new int[201], iChar; nArray[0] = 0; long rMulti;
  java.io.FileReader iFile = null; java.io.FileWriter oFile = null;
  try{
   iFile = new java.io.FileReader(fileName);
   while((iChar = iFile.read())!=-1)
    if(iChar!=' ')aNum+=(char)iChar;
    else {nArray[++nArray[0]] = new Integer(aNum);aNum="";}
   if(!aNum.equals(""))nArray[++nArray[0]] = new Integer(aNum);
   oFile = new java.io.FileWriter(fileName);
   for(rMulti = 1; nArray[0]>0; nArray[0]--)rMulti*=nArray[nArray[0]];
   oFile.write(rMulti+"");
  }catch(java.io.FileNotFoundException fnfe){
   System.out.println("Файл не был найден!");
  }catch(java.io.IOException ioe){
   System.out.println("Ошибка ввода/вывода в файл!");
  }finally{
   try{
 iFile.close(); oFile.close();
   }catch(java.io.IOException ioe){
 System.out.println("Ошибка закрытия файла ввода/вывода!");
   }
  }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота