Madi12kz
15.02.2021 07:42

Составить программу вычисления суммы элементов одномерного массива А[1..10].

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pomogite228plez
20.02.2021 04:45

pascal

Объяснение:

1)

const n = 20;

var i, s: integer;

   a: array[1..n] of integer;

begin

 randomize;

 for i := 1 to n do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if a[i] > 9 then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма элементов, больших 9, равна ', s);

end.

2)

const n = 20;

var i, s: integer;

   a: array[1..n] of integer;

begin

 randomize;

 for i := 1 to n do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if a[i] mod 2 = 0 then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма четных элементов равна ', s);

end.

0,0(0 оценок)
Ответ:
Лиза13061
20.03.2023 18:59

скрин

Объяснение:

print ("a | b | c | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11")

for a in range (2):

   for b in range (2):

       for c in range(2):

           print("%1d%4d%4d%4d%4d%4d%4d%4d%4d%4d%4d%4d%5d%5d" % (a,b,c,int(not a),int(not a or c),int(a and c),int(not(a and c)),int((not a or c)and(not(a and c))),int(not c),int(b or not c),int((not a or c)and(not(a and c))and(b or not c)),int(b and c),int(not(b and c)),int((not a or c)and(not(a and c))and(b or not c)and(not(b and c)))))

print()

print ("1 - не a, 2 - не a v c, 3 - a*c,4 - не(a*c), 5 - (не a v c)*(не(a*c)), 6 - не c, 7 - b v не c, 8 - (не a v c)*(не(a*c))*(b v не c)")

print ("9 - b*c, 10 - не(b*c), 11 - (не a v c)*(не(a*c))*(b v не c)*(не(b*c))")


Построить таблицу истинности
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота