Алексей08032005
28.08.2020 23:50

Найти произведение нечетных элементов массива от 1 до 100, массив нужен на русском

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
НикаБахметьева
21.05.2022 01:22

Какой оператор цикла желательно использовать, если известно число повторений тела цикла?

repeat <оператор1, …>until <условие>

while <условие>do <оператор>

for <параметр>:= <начальное значение>to<конечное значение> do<оператор>

2. Используется оператор for i:= -10 to 10 do…

После завершения выполнения тела цикла i = 10

3. Цикл в фрагменте программы

p:=1;

repeat

p:=p*0.1

until p>0.1;

будет исполнен:

1 раз

2 раза

бесконечное число раз

0 раз

3 раза

4. Цикл в фрагменте программы

a:=1;

b:=1;

while a+b<8 do

begin

a:=a+1; b:=b+2

end;

выполнится:

0 раз

3 раза

2 раза

1 раз

бесконечное число раз

5. Какой оператор цикла желательно использовать для записи алгоритмической конструкции, изображённой на схеме?

НЕТ СХЕМЫ. ОТВЕТИТЬ НА ВОПРОС НЕВОЗМОЖНО.

while <условие> do <оператор>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

repeat <оператор1, …> until <условие>

6. Какой оператор цикла желательно использовать, если известно условие выхода из цикла?

repeat <оператор1, …> until <условие>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

while <условие> do <оператор>

7. Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:

a:=1; b:=1;

while a<=32 do a:=a*2; b:=b*a;  //Обратите внимание! Нет begin end.

write (b)

32

256

64

128

8. Используется оператор for i:= -5 to 9 do…

При первом выполнении тела цикла i = -5

9. Чему равно значение переменной s после выполнения следующего фрагмента программы

Фрагмента программы нет! Задание решить нельзя!

0,0(0 оценок)
Ответ:
Fkbyfitdxtyrj
03.06.2021 15:06
Есть растровая и векторная графика

Растровая - все изображение составлено из пикселей, точек, которые имеют свой цвет и расположение. Чем больше этих пикселей - тем лучше качество картинки. Недостатки: при большом масштабировании теряется качество (наверняка замечали квадраты при увеличении картинки) и еще один недостаток - объем файла, нужно задать цвет для каждого пикселя

Векторная графика - изображение состоит из примитивов (точка, линии, прямоугольники, окружности и прочее). Такое изображение легко увеличивается и уменьшается без потери качества, объем информации в файле меньше, (в файле хранятся не пиксели а параметры фигур: размер, цвет или радиус круга) но для сложных рисунков понадобится ОЧЕНЬ много точек и прямоугольников :D
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота