Nurayka269
25.02.2020 05:34

Python Все вместе

Дано натуральное число. Напишите программу, которая вычисляет:

сумму его цифр;

количество цифр в нем;

произведение его цифр;

среднее арифметическое его цифр;

его первую цифру;

сумму его первой и последней цифры.

Формат входных данных

На вход программе подается одно натуральное число.

Формат выходных данных

Программа должна вывести значения указанных величин в указанном порядке.

Sample Input 1:

5678

Sample Output 1:

26

4

1680

6.5

5

13

Sample Input 2:

132

Sample Output 2:

6

3

6

2.0

1

3

Sample Input 3:

75

Sample Output 3:

12

2

35

6.0

7

12

Напишите программу. Тестируется через stdin → stdout

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nikita45Nikita45
05.10.2022 08:01

1.комбинация компьютерных инструкций и данных, позволяющая аппаратному обеспечению вычислительной системы выполнять вычисления или функции управления

2. программа или множество программ, используемых для управления компьютером.

3.на: - системное ПО; - прикладное ПО; - системы программирования.

4. программа, предназначенная для выполнения определённых задач и рассчитанная на непосредственное взаимодействие с пользователем.

5. комплекс взаимосвязанных программ, предназначенных для управления ресурсами компьютера и организации взаимодействия с пользователем.

6. компьютерное программное обеспечение, с которого другое программное обеспечение получает доступ к аппаратному обеспечению некоторого устройства.

7.являются составной частью программ установленных вместе с операционной системой.

8. Windows (7,8,10), Linux и IOS

Объяснение: ---

0,0(0 оценок)
Ответ:
haka228
05.10.2022 08:01
//Визуально разделил циклы, чтобы было более читаемо 

var ar:array[1..10] of integer;
max,i:integer;
begin;
randomize; //чтобы random() работал как надо
writeln('Array');

for i:=1 to 10 do
begin;
ar[i]:=random(-10,10); //случайное число от -10 до 10
write(ar[i]:4);
end;

for i:=1 to 10 do //"проходим" через весь массив
if (ar[i]<0) and (max<abs(ar[i])) then max:=abs(ar[i]);
{если элемент массива меньше нуля и его модуль больше максимума тогда записать модуль этого числа в максимум}

writeln;
writeln('Max:-',max); //выводим на всякий случай максимум

writeln('Final array:');
for i:=1 to 10 do //снова проходим по всему массиву
begin;
if ar[i]=-max then ar[i]:=0; 
{если элемент равен отрицательному максимуму(мы брали модуль) присвоить ему 0}
write(ar[i]:4);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота