masha91672
01.05.2020 09:54

написать программу на Python которая находит произведение первых А натуральных чисел. Число А вводится с клавиатуры ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lenusja272
23.03.2023 17:26

n = int(input()) # получаем кол-во продуктов и записываем в n

a = {} # библиотека для цен

c = {} # библиотека для кол-во продукта

l = [] # массив для всех проданных продуктов

for i1 in range(n): # цикл для заполнения всех массивов

   b = [] # массив b для отделения цены о названия продукта

   b.append(input().split()) # записываем продукт и его цену в массив b

   k = int(b[0][len(b[0])-1]) # записываем в k цену продукта

   v = ''

   for i in range(len(b[0])-1): # при цикла объединяем название в                одну строчку и записываем в v

       v = v + str(b[0][i]) + ' '

   l.append(v) # добавляем название в массив l

   a[v] = k # добавляем цену и продукт в библиотеку a

   c[v] = 0 # добавляем продукт в библиотеку b

for i in range(len(l)): # записываем при цикла кол-во каждого продукта

   c[l[i]] = c[l[i]]+1

print(len(c)) # выводим кол-во продуктов, которые были проданы

for i in a: # при цикла выводим продукт и сколько за него в итоге заплатили

   print(str(i)+str(a[i]*c[i]))

Объяснение

0,0(0 оценок)
Ответ:
katekotloveka
13.04.2022 18:53

1

x = int(input('Введите x: '))

print('y =', 2 * pow(x, 0.5))

print('y =', pow(x + 2, 2))

print('z =', 14 * pow(x, 2) + 11 - 17)

2

import math

s, v_1, v_2 = int(input('Введите S: ')), int(input('Введите v1: ')), int(input('Введите v2: '))

print(math.ceil(s / (v_1 + v_2)))

И кстати, пример не правильный, т.к. когда вы используете просто команду input(), то она не преобразует строку в число, а оставляет ее строкой, то есть если вы ввели 5, то и  переменная будет хранить значение '5' как строку(как слово), а строковый тип не поддерживает операцию перемножения саму на себя, то есть если вы умножите '5'(типа str) на '5'(типа str) это будет соответствовать умножению слова 'гриб' на слово 'дерево', а это невозможно.

Чтобы исправить эту ошибку нужно 'оборачивать' input() в int(), то есть должно получиться int(input()), как написал я.  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота