danilf999
10.12.2022 21:08

Написать программу, которая вычисляет стоимость покупки, состоящей из нескольких линеек, нескольких маркеров и одной файловой папки. Хорошо продумай, какие исходные данные нужны для этой программы, как выглядит формула вычисления покупки​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kotBarsik14
24.05.2020 15:28

1) Если имя переменной в себе содержит больше одного слова, то оно всё равно целиком должно быть написано слитно, иначе SyntaxError

birth day -> BirthDay или birthDay или birth_day

2) # Step 3: if * > **: age = year - birth_year then:

    - Переменная birth_year ранее не объявлена

    - как интерпретатор должен осознать значение выражения " if * > ** " ?

    - Откуда там взялся then: ?

3) print("Your age: {a} years, {b} months, {c} days"):

    - Перед форматированной строкой должен стоять флаг f:

      print(f' value: {value}')

Вывод: Изучите основы синтаксиса Python

0,0(0 оценок)
Ответ:
KristinaPech
28.07.2022 02:02
1. Ну я не знаю какая часть фигуры закрашена. Будем считать что прямоугольник находиться в окружности и необходимо из площади курга вычесть площадь прямоугольника.
const
p =3.14;
var
a,b,r,s1,s2:real;
begin
Writeln('Введите длины сторон прямоугольника');
readln(a,b);
Writeln('Введите радиус окуржности');
Readln(r);
s1:=a*b;
s2:=p*sqr(r);
Writeln('Площадь закрашеной окружности = ', s2-s1);
end.

Если закрашена какая-то другая область то можете просто изменить действие с площадями в предпоследней строчке ( в данном случае мы из s2 вычитаем s1).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота