AgsHiNN05I
11.03.2023 21:44

написать программу нахождения суммы и произведения натуральных чисел до n числа через цикл с предусловием и через счётчик ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ab198me
28.01.2022 10:44

§1.  о системах счисления.

  n4. развернутая форма записи числа

 

из курса вам известно, что цифры десятичной записи числа – это просто коэффициенты его представления в виде суммы степеней числа – основания системы счисления:

       

      25076 = 2*10000 + 5*1000 + 0*100 + 7*10 + 6*1 = 2*104  +5*103  + 0*102  +7*101+6*100

 

при переводе чисел из десятичной системы счисления в римскую мы и воспользовались этим правилом (444 = 400 + 40 + 4;   2986 = 2000 + 900 + 80 + 6).

при записи чисел значение каждой цифры зависит от ее положения. место для цифры в числе называется разрядом, а количество цифр в числе разрядностью. на самом деле числа можно записывать как сумму степеней не только числа 10, но и любого другого натурального числа, большего 1.

 

определение.  развернутой формой записи числа называется такая запись: а4а3а2а1а0  = а4*q4  + a3*q3  + a2*q2  + a1*q1  + a0*q0  , где а4,а3,а2,а1,а0  –цифры числа, q –основание степени.

 

 

пример1.  получить развернутую форму числа 7512410.

решение:

  а4  = 7, а3  = 5, а2  =1 ,а1  =2, а0  =4,          q=10

 

4 3 2 1 0

75 12410  = 7*104  + 5*103  + 1*102  + 2*101  + 4*100.

 

 

пример2.  получить развернутую форму числа 1123.

решение:

 

2 1 0

1123  = 1*32  + 1*31  +2*30

 

пример3.  получить развернутую  форму числа  176,218.

решение:                     21 0-1-2а8=176, 218=1*82+7*81+6*80+2*8-1+1*8-2  для самостоятельной работы: 1. запишите в развернутом виде числа: а8=143511,62а2=100111а10=143,511а16=1а3,5с12. запишите в свернутой форме число: 9*101+1*100+5*10-1+3*10-2a*162+1*161+c*160+3*16-1
0,0(0 оценок)
Ответ:
Miya5koka
16.11.2020 20:38
Задача №1

var a:array [1..20] of integer;     
i:integer;
begin 
randomize;   
for i:=1 to 20 do begin   
a[i]:=random(19-(-10)+1)+-10;     
write (a[i],' ');           
end;
end.

Задача №2

var a:array [1..20] of integer; 
i:integer; 
begin 
writeln('Введите числа в интервале [-20;29]'); 
for i:=1 to 10 do read(a[i]); 
for i:=1 to 10 do 
if (a[i]>-29) and (a[i]<20) then write(a[i],' '); 
end.

Задача №3

var a:array [1..20] of integer; 
i,sum:integer; 
begin 
randomize; 
sum:=0; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
write (a[i],' '); 
if a[i]>0 then sum:=sum+1; 
end; 
writeln('Количество положительных элементов массива = ', sum); 
end.

Задача №4

var a:array [1..20] of integer; 
i:integer; 
begin 
randomize; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
if a[i]<0 then a[i]:=0; 
write (a[i],' '); 
end; 
end.

Задача №5

var a:array [1..20] of integer; 
i,sum:integer; 
begin 
randomize; 
sum:=0; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
write (a[i],' '); 
if a[i]>0 then sum:=sum+a[i]; 
end; 
writeln('Сумма положительных элементов массива = ', sum); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота