nastiamakeeva0
23.01.2020 04:36

Вычислите значения выражений на языке Python:
Напишите программу для нахождения k, если x и y вводятся с клавиатуры


Вычислите значения выражений на языке Python: Напишите программу для нахождения k, если x и y вводят

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kazhyal
31.07.2020 01:31

1.Интегрированная среда разработки IDE это? –

а) программная надстройка, которая позволяет программисту разрабатывать программное обеспечение.

б) графическая программа, которая позволяет программисту разрабатывать программное обеспечение.

в) текстовый процессор, позволяющий программисту разрабатывать программное обеспечение.

2.Запуск программы на выполнение осуществляется? Запишите команду – py (Windows), python (На Mac, Ubuntu)

3. Установите соответствие:

Значение

Тип данных

1) 5 int

а)float

2) 6.2 float

б)str

3) ' информатика' str

в)int

4.Проанализируйте программу. Определите тип данных указанный для переменной а.

a = int(input(’Введите число’))

b=5

c=a+b

print(c)

a: int

5. Дано математическое выражение. Запишите, как оно будет записано в языке программирования Python?

4x-2b

x, b = 2, 3 # Любые числа

4*x - 2*b

6.Укажите функцию ввода в языке программирования Python.

а)int

б) print

в) input

7. Укажите функцию вывода в языке программирования Python.

а)int

б) print

в) input

8. Дана программа: –

a=int(input(‘Введите значение а’))

b=10

s=2*a+b

print(‘Значение выражения :’, s)

Определите и запишите:

а)тип данных переменной а: int

б)значение переменной b: 10

в) формулу нахождения переменной s = 2*a + b

0,0(0 оценок)
Ответ:
timurev
11.08.2022 11:29
Ваша программа:

import math

x = float(input('Введите аргумент Х точки: '))

if -3 <= x < -1:

   y = -x + 1

elif -1 <= x < 1:

   y = 0

elif 1 <= x < 5:

   y = math.sqrt(4 - (x-3)*(x-3))

elif 5 <= x < 7:

   y = -(x/2)+2.5

else:

   print('Х вне допустимого диапазона')

   input()

   exit()

print('Точка с координатами %2.2f ; %2.2f'%(x, y))

А это так, для интереса и наглядности:

import turtle, math

def line(x1,y1,x2,y2):

   turtle.pu()

   turtle.goto(x1,y1)

   turtle.pd()

   turtle.goto(x2,y2)

   turtle.pu()

   

turtle.title('График функции')

turtle.setup(800,400)

turtle.setworldcoordinates(-4,-2,8,4)

turtle.hideturtle()

line(-4,0,8,0)

line(0,-2,0,4)

for x in range(-3,8):

   line(x,-0.1, x, 0.1)

for y in range(-1, 4):

   line(-0.1,y,0.1,y)

turtle.pensize(2)

line(-3,2,-1,0)

line(-1,0,1,0)

turtle.pd()

x = 1

while x < 5:

   turtle.goto(x, math.sqrt(4 - (x-3)*(x-3)))

   x += 0.01

line(5,0,7,-1)

x = float(input('Введите аргумент Х точки: '))

turtle.pencolor('red')

if -3 <= x < -1:

   y = -x + 1

elif -1 <= x < 1:

   y = 0

elif 1 <= x < 5:

   y = math.sqrt(4 - (x-3)*(x-3))

elif 5 <= x < 7:

   y = -(x/2)+2.5

else:

   print('Х вне допустимого диапазона')

   input()

   exit()

y1 = '%2.2f'%y

print('y = %2.2f'%y)

turtle.pu()

turtle.goto(x,y)

turtle.dot(7, 'red')

turtle.pensize(1)

turtle.pencolor('green')

line(x,y,0,y)

line(x,y,x,0)

turtle.goto(0.5,3.5)

turtle.write('Точка ('+str(x)+'; '+y1+')', font=('Arial',10))

turtle.exitonclick()


написать код на языке
написать код на языке
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота