Keksikkk228
22.10.2021 08:14

Составьте программу на вычисление массовой доли растворённого вещества в общей массе раствора, если известны все значения. При вводе значений 0 для данных переменных, программа выводит сообщение «Введите корректные значения» в C#

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Данила4688
23.06.2021 06:20

1)

 

var
a, b: integer;
begin
writeln('Введите a, b: '); readln(a, b);
if(b mod a = 0) then writeln('Является делителем')
else writeln('Не является делителем');
end.

 

2)

 

var
x, y, tmp: real;
begin
repeat
writeln('Введите x, y: '); readln(x, y);
until(x <> y);
if(x > y) then begin
tmp := y;
y := (x + y) / 2;
x := 2*(x * tmp);
writeln('Большее - X = ', x, ' Меньшее - Y = ', y);
end else begin
tmp := x;
x := (x + y) / 2;
y := 2*(tmp * y);
writeln('Большее - Y = ', y, ' Меньшее - X = ', x);
end;
end.

 

0,0(0 оценок)
Ответ:
Atems564
22.05.2023 23:13

Код:

using System;

namespace WordsCounter

{

   class Bishop

   {

       private int x, y;

       public Bishop(int x, int y)

       {

           this.x = x;

           this.y = y;

       }

       public bool CanIAttackIt(int x, int y)

       {

           return Math.Abs(x - y) == Math.Abs(this.x - this.y);

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           var x0 = int.Parse(Console.ReadLine()!);

           var y0 = int.Parse(Console.ReadLine()!);

           var x = int.Parse(Console.ReadLine()!);

           var y = int.Parse(Console.ReadLine()!);

           Console.WriteLine((new Bishop(x0, y0)).CanIAttackIt(x, y));

       }

   }

}


На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота