Zero00000
29.03.2023 12:25

Составить программу решения следующей задачи: Дана масса в граммах. Вычислите массу в фунтах (1 фунт=453г) и унциях (1 унция=28г).​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
3Человек3
11.07.2022 06:29

Разбираешься в компьютерах и играх, но не разбираешься в программирование. Я могу сделать вывод, что ты играл на протяжении 6 лет в игры и собирал себе компьютер для игр

Думаю ты не разбираешься во внутренностях компьютера.

Экзамены перенесли на август, мои тебе советы:

Готовься к ЕГЭ

Смотри видео уроки по профильной математике ЕГЭ от Павла Маслова (Ютуб)

Физику смотри также на Ютубе (Пенкин)

Также могу тебе посоветовать решать каждый день по 15 вариаций заданий, которые ты например выучил решения первого задания матана, решай их как можно больше)

Сдай ЕГЭ

Без него ничего не выйдет

0,0(0 оценок)
Ответ:
Ertadaysma
24.10.2020 07:27

#include <bits/stdc++.h>

using namespace std;

int main(){

int n, negativeIndex = 0, positiveIndex = 0, buf = 0;

bool a, b = false;

cin >> n;

int arr[n];

for(int i = 0; i < n; ++i){

 cin >> arr[i];

}

for(int i = 0; i < n; ++i){

 if(arr[i] < 0){

  negativeIndex = i;

  a = true;

  break;  

 }

}

for(int i = n-1; i >= 0; --i){

 if(arr[i] >= 0)

  positiveIndex = i;

  b = true;

  break;

}

if(a && b){

buf = arr[negativeIndex];

arr[negativeIndex] = arr[positiveIndex];

arr[positiveIndex] = buf;

}

for(int i = 0; i < n; ++i){

 cout << arr[i] << "\t";

}

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота