vyrov08
13.03.2023 21:24

Напишите программу, на любом языке


Напишите программу, на любом языке

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Søphia
30.09.2021 18:58
(1.) Функции:
     1.) Обмен данными между компьютером и различными периферийными устройствами (терминалами, принтерами, гибкими дисками, жесткими дисками и т.д.)
     2.) Обеспечение системы организации и хранения файлов.
     3.) Загрузка программ в память и обеспечение их выполнения.
     4.) Организация диалога с пользователем.
 (2.) Без BIOS не запустится загрузчик, который находиться на системном диске, а без загрузчика не запустится OC. 
 (3.) Набор методов взаимодействия компьютерной программы и пользователя этой  программы.
0,0(0 оценок)
Ответ:
Margarita12071
11.03.2022 23:20
1) var a,b,x:real;
begin
write ('введите числа а и b: '); readln(a,b);
x:=-b/a;
writeln('x= ',x);
end.
2) var r1,r2,s:real;
begin
write ('введите размеры внешнего и внутреннего радиусов: '); read(r1,r2);
s:=pi*r1*r1-pi*r2*r2;
write ('Площадь кольца = ',s);
end.
3) var a,b,c,s,p:real;
begin
write ('введите длины катетов: '); read(a,b);
s:=a*b/2;
c:=sqrt(a*a+b*b);
p:=a+b+c;
write ('Площадь треугольника = ',s);
write ('Периметр треугольника = ',p);
end.
4)  var a,b,sr:real;
begin
write ('введите числа а и b: '); readln(a,b);
sr:=(abs(a)+abs(b))/2;
writeln('среднее арифметическое модулей = ',sr );
end.

5) var x1,y1,x2,y2,r:real;
begin
write ('введите координаты точек: '); readln(x1,y1,x2,y2 );
r:=sqrt ( sqr(x2-x1)+sqr (y2-y1));
writeln('расстояние = ',r );
end.
6)  var a,b,h, s, p:real;
begin
write ('введите длины оснований и высоту трапеции: '); readln(a,b,h);
s:=(a+b)*h/2;
p:=a+b+h+sqrt (sqr(abs(a-b))+h*h);
write ('Площадь трапеции = ',s);
write ('Периметр трапеции= ',p);
end.
7) var a,e,d,s, p:integer;
begin
write ('введите трехзначное число: '); readln(a);
e:=a mod 10; s:=a div 100;
d:= (a div 10) mod 10; p:=e*d*s;
write ('разность между трехзначным числом и его произведением = ',a-p);
end.
 к твоему комментарию 
var x,s,m,c: integer;
begin
write('введите количество секунд: ');readln(x);
c:=x div 3600;
m:= (x mod 3600) div 60;
s:=(x mod 3600) mod 60;
часов ',m,' минут ', s,' секунд ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота