pro9377196
09.03.2023 00:07

Дан одномерный массив B [N] , (0 меньше N меньше 50). В этом массиве поменяйте местами m-ый элемент с К-ым элементом и выведите на печать полученный массив подробно если можете )) сор , очень нужно​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Даниил5356
06.03.2020 05:30
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4
0,0(0 оценок)
Ответ:
gjrdghhFafhj
03.03.2020 06:37
Логические знаки не дает вставлять - пишу их союзами и частицами подчеркнутыми.
1)   Число  376 четное и трехзначное.
А = "Число  376 четное"
В = "Число  376 трехзначное"
А и В 
2) Неверно, что Солнце движется вокруг Земли.
А = "Солнце движется вокруг Земли"
Не А
3) Земля имеет форму шара.
А = "Земля имеет форму шара"
А
4) На уроке математики старшеклассники отвечали на вопросы учителя и писали самостоятельную работу.
А = "На уроке математики старшеклассники отвечали на вопросы учителя"
В = "На уроке математики старшеклассники писали самостоятельную работу"
А и В
5) Если сумма цифр числа делится на 3, то число делится  на  3.
А = "Сумма цифр числа делится на 3"
В = "Число делится  на  3"
А стрелка к  В
6) Число  делится на 3 тогда и только тогда, когда сумма цифр числа  делится на 3
А = "Число  делится на 3 "
В = "Сумма цифр числа  делится на 3"
А стрелка в обе стороны В
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота