GeBorgge
21.05.2022 12:27

С# Программирование 2. Напишите полную и неполную форму условного оператора на языке объектно-ориентированного программирования (C#).

3. Составьте программу, проверяющую, принадлежит ли число, введенное с клавиатуры, интервалу (-10;10).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Алалутала
10.04.2022 22:04

const

 nn = 25; // максимум слов

var

 a: array[1..nn] of string[20];

 

procedure Parser(s: string; var k: integer);

var  

 i,n: integer;

 w: string;

begin  

 w := '';

 k := 0;

 n := length(s);

 for i := 1 to n do

   if s[i] <> ' ' then w := w + s[i]

   else

     if length(w) > 0 then

     begin

       k := k + 1;

       a[k] := w;

       w := '';

     end;

 if length(w) > 0 then

 begin

   k := k + 1;

   a[k] := w;

 end;

end;

 

var

 s: string[254];

 i, k: integer;

 

begin

 Readln(s);

 Parser(s, k);

 for i := 1 to k do

   if Pos('ар', a[i]) > 0 then

     write(a[i], ' ');

end.

Программа уровня Турбо Паскаль

0,0(0 оценок)
Ответ:
boss110
10.04.2022 22:04

const

 nn = 25; // максимум слов

var

 a: array[1..nn] of string[20];

 

procedure Parser(s: string; var k: integer);

var  

 i,n: integer;

 w: string;

begin  

 w := '';

 k := 0;

 n := length(s);

 for i := 1 to n do

   if s[i] <> ' ' then w := w + s[i]

   else

     if length(w) > 0 then

     begin

       k := k + 1;

       a[k] := w;

       w := '';

     end;

 if length(w) > 0 then

 begin

   k := k + 1;

   a[k] := w;

 end;

end;

 

var

 s: string[254];

 i, k: integer;

 

begin

 Readln(s);

 Parser(s, k);

 for i := 1 to k do

   if Pos('ар', a[i]) > 0 then

     write(a[i], ' ');

end.

Программа уровня Турбо Паскаль

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота