Angelm00n
03.01.2020 11:48

Составить программу. Найти количество всех чисел кратных 5 от 27 до 58 ТОЛЬКО ЧЕРЕЗ БЫСТРЕЕ !
БЫСТРЕЕ !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
qwelsaqwelsa
19.03.2023 12:49

m, n, i, j: integer;

 s: real;

 a: array[,] of real;

 

 write('Введите S: ');

 read(s);

 write('Введите M, N: ');

 read(m, n);

 setlength(a, m + 1, n + 1);

 writeln('Введите элементы матрицы: ');

 for i := 1 to m do

   for j := 1 to n do

     read(a[i, j]);

 for i := 1 to m do

 begin

   for j := 1 to n do  

     if a[i, j] <> s then

     begin

       writeln(a[i, j]);

       break;

     end;

   if a[i, j] = s then

     writeln('-');

 end;

end.

Пример:

Введите S: 7

Введите M, N: 3 4

Введите элементы матрицы:

7 4 3 7

3 5 1 4

7 7 7 7

4

3

-

Объяснение:

нажмите лучших ответ и лайк

0,0(0 оценок)
Ответ:
nurija090675
25.10.2021 12:30

Вещественные числа обычно представляются в виде чисел с плавающей запятой. Числа с плавающей запятой — один из возможных представления действительных чисел, который является компромиссом между точностью и диапазоном принимаемых значений, его можно считать аналогом экспоненциальной записи чисел, но только в памяти компьютера.

Число с плавающей запятой состоит из набора отдельных двоичных разрядов, условно разделенных на так называемые знак (англ. sign), порядок (англ. exponent) и мантиссу (англ. mantis). В наиболее распространённом формате (стандарт IEEE 754) число с плавающей запятой представляется в виде набора битов, часть из которых кодирует собой мантиссу числа, другая часть — показатель степени, и ещё один бит используется для указания знака числа (0 — если число положительное, 1 — если число отрицательное). При этом порядок записывается как целое число в коде со сдвигом, а мантисса — в нормализованном виде, своей дробной частью в двоичной системе счисления. Вот пример такого числа из 16 двоичных разрядов:

Знак

Порядок Мантисса

0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

14 10 9 0

Знак — один бит, указывающий знак всего числа с плавающей точкой. Порядок и мантисса — целые числа, которые вместе со знаком дают представление числа с плавающей запятой в следующем виде:

(−1)S×M×BE, где S — знак, B — основание, E — порядок, а M — мантисса. Десятичное число, записываемое как ReE, где R — число в полуинтервале [1;10), E — степень, в которой стоит множитель 10; в нормализированной форме модуль R будет являться мантиссой, а E — порядком, а S будет равно 1 тогда и только тогда, когда R принимает отрицательное значение. Например, в числе −2435e9

S = 1

B = 10

M = 2435

E = 9

Порядок также иногда называют экспонентой или просто показателем степени.

При этом лишь некоторые из вещественных чисел могут быть представлены в памяти компьютера точным значением, в то время как остальные числа представляются приближёнными значениями.

Более простым вариантом представления вещественных чисел является вариант с фиксированной точкой, когда целая и вещественная части хранятся отдельно. Например, на целую часть отводится всегда X бит и на дробную отводится всегда Y бит. Такой в архитектурах процессоров не присутствует. Отдаётся предпочтение числам с плавающей запятой, как компромиссу между диапазоном допустимых значений и точностью

Объяснение:

Вот надеюсь

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота