Fakla
19.02.2020 08:30

Дан массив в=[5,10,15], запишите программный код для вычисления суммы элементов в данном массиве​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kontik20033002
28.12.2021 17:38

Задание №1. Наименьшее число

Даны целые числа a, b, c. Найдите наименьшее из них.

Программа на Python:

n1, n2 = map(int, input().split())

print(n1 if n1 < n2 else n2)

Задание №2. Количество разрядов

Даны целые числа a, b, c. Найдите количество разрядов этих чисел

Программа на Python:

a, b, c = map(int, input().split())

print(len(str(a)), len(str(b)), len(str(c)))

Задание №3. Исследование треугольника

Даны целые числа a, b,c. Используя эти числа, можно получить три прямоугольника. Для каждого образованного прямоугольника найдите площадь и периметр. Запишите результат в следующем порядке - стороны прямоугольника, его площадь и периметр.

Программа на Python:

a, b, c = map(int, input().split())

print(a, b, a * b, 2*(a + b))

print(b, c, b * c, 2*(b + c))

print(a, c, a * c, 2*(a + c))

0,0(0 оценок)
Ответ:
VadAltman13
16.11.2022 19:50
Решение №1 (без массивов)

var a,n,i,j,s:integer;
begin
  writeln('Введите количество цифр в числе');
  readln(n);
  for i:=1 to n do begin
    writeln('Введите ',i,' цифру из ',n);
    readln(a);
    for j:=1 to n-i do a:=a*10;
    s:=s+a;
  end;
  writeln('Натуральное число: ',s);
end.

Тестовое решение

Введите количество цифр в числе
5
Введите 1 цифру из 5
9
Введите 2 цифру из 5
2
Введите 3 цифру из 5
7
Введите 4 цифру из 5
3
Введите 5 цифру из 5
1
Натуральное число: 92731

Решение №2 Если очень надо использовать массив (хотя на мой взгляд совсем не нужно)

//PascalABC.NET (версия 3.1, сборка 1198)
var a,n,i,j,s:integer;
mas:array[1..10]of integer;
begin
  writeln('Введите количество цифр в числе');
  readln(n);
  for i:=1 to n do begin
    writeln('Введите ',i,' цифру из ',n);
    readln(mas[i]);
    a:=mas[i];  
    for j:=1 to n-i do a:=a*10;
    s:=s+a;
  end;
  writeln('Натуральное число: ',s);
end.

Тестовое решение

Введите количество цифр в числе
5
Введите 1 цифру из 5
5
Введите 2 цифру из 5
4
Введите 3 цифру из 5
3
Введите 4 цифру из 5
2
Введите 5 цифру из 5
2
Натуральное число: 54322
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота