LIKA03072017
03.09.2022 03:32

Напишите 2 задачки на питоне, а не на паскале. Кто напишет на паскале реп. 1) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2.
2) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Reginka24082007
31.07.2022 12:40
Запись файла любого типа и использование диска на компьютере с Windows XP или более поздней версией.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW или DVD-RAMФормат:‌ файловая система LFSЗапись файла любого типа и использование диска на любом компьютере, где могут быть установлены версии Windows, более ранние, чем Windows XP.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW или DVD-RAMФормат: MasteredЗапись файла любого типа и использование диска на компьютере с Windows Vista или более поздней версией.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW, DVD-RAM, BD-R или BD-REФормат:‌ файловая система LFS или MasteredЗапись музыки или изображений и использование диска на некоторых обычных проигрывателях компакт-дисков, DVD-дисков или дисков Blu-ray, воспроизводящих МР3-файлы и цифровые изображения.Диск: CD-R, CD-RW, DVD-R, DVD+R, DVD-RW или DVD+RWФормат: MasteredЗапись музыки и изображений и использование диска на любом компьютере, где могут быть установлены версии Windows, более ранние, чем Windows XP.Диск: CD-R, CD-RW, DVD-R, DVD+R, DVD-RW или DVD+RWФормат: MasteredВозможность многократного добавления и стирания одного или множества файлов (как в случае использования USB-устройства флэш-памяти) и использование диска на компьютерах с Windows XP или более поздней версией.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW или DVD-RAMФормат: LFSВозможность многократного добавления и стирания одного или множества файлов (как в случае использования USB-устройства флэш-памяти) и использование диска на компьютерах с Windows 7.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW, DVD-RAM, BD-R или BD-REФормат: файловая система LFSНахождение диска в устройстве записи компьютера, копирование на него файлов, например, для резервного храненияДиск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW, DVD-RAM, BD-R или BD-REФормат: файловая система LFS
0,0(0 оценок)
Ответ:
ржакаmaker
27.11.2021 15:08
var i: integer; begin // С С С Вывод последовательности 1 3 5 7 9var i,x: integer; begin // С и промежуточной переменной x := 1; for i := 1 to 5 do begin write(x,' '); x := x + 2; end; writeln;   // С без промежуточной переменной for i := 1 to 5 do write(2*i-1,' '); writeln;   // С С Сумма и произведение введенных чиселКод на Pascalvar i: integer; s,p: real; x: real; begin writeln('Введите 10 чисел: '); s := 0; p := 1; for i := 1 to 10 do begin read(x); s := s + x; p := p * x; end; writeln('Сумма введенных чисел = ',s); writeln('Произведение введенных чисел = ',p); end.Код на PascalABC.NETvar s,p: real; begin writeln('Введите 10 чисел: '); s := 0; p := 1; for var i := 1 to 10 do begin var x: integer; read(x); s += x; p *= x; end; writeln('Сумма введенных чисел = ',s); writeln('Произведение введенных чисел = ',p); end.Вычисление n!Код на Pascalvar n,fact: integer; i: integer; begin write('Введите n (n<=13): '); readln(n); fact := 1; for i := 2 to n do fact := fact * i; writeln(n,'! = ',fact); end.Код на PascalABC.NETvar n: integer; begin write('Введите n (n<=13): '); readln(n); var fact := 1; for var i := 2 to n do fact *= i; writeln(n,'! = ',fact); end.Вычисление AnКод на Pascalvar n,i: integer; a,p: real; begin write('Введите a,n: '); readln(a,n); p := 1; for i := 1 to n do p := p * a; writeln(a,' в степени ',n,' = ',p); end.Код на PascalABC.NETvar n: integer; a: real; begin write('Введите a,n: '); readln(a,n); var p := 1.0; for var i := 1 to n do p *= a; writelnFormat('{0} в степени {1} = {2}',a,n,p); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота