MrQelen
14.01.2021 14:35

2. Составьте программу для вывода на экран предложения «Хорошего дня ​это СОР

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nina19862
08.11.2022 15:46
Const n=10; 
var a:array[1..n] of integer;
i,s,min:integer;
begin
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
s:=0; 
min:=a[1];
for i:=1 to n do
 begin
 if a[i]>0 then s:=s+a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('s = ',s,'   min = ',min);
for i:=1 to n do
 if a[i]>0 then a[i]:=s
  else if a[i]<0 then a[i]:=a[i]-min;
writeln('Измененный массив:');
for i:=1 to n do  write(a[i]:4);
writeln;
end.

Пример:
Исходный массив:
   9  -3  -5   7   1   5  -6   9  -8   7
s = 38   min = -8
Измененный массив:
  38   5   3  38  38  38   2  38   0  38
0,0(0 оценок)
Ответ:
andreykolomoytsev
24.04.2021 01:34
На алгоритмическом.

a=массив(10..50);
max:=a[1]'
min:=a[1];
n_min:=0;
n_max:=0;
k:=0;
i:=10;

пока i<=50  делай
нц
  если a[i]>max то
    нц
     max:=a[i];
     n_max:=i;
    кц
  если a[i]<min то
   нц
    min:=a[i];
    n_min:=i;
   кц
 если (i mod 2)==0 то
   sum:=sum+a[i]; 
   k:=k+1;
кц

srednee_znachenie:=sum/k;

//

var
a:array(10..50) of integer;
max,min,n_min,n_max,k,i,sum:integer;
sr:float;

begin
 max:=a[1];
 min:=a[1];

 for i:=10 to 50 do
  begin
   if a[i]>max then
    begin
     max:=a[i];
     n_max:=i;
    end;
   if a[i]<min then
    begin
     min:=a[i]
     n_min:=i;
    end;
   if ((i mod 2)=0) then
    begin
     k:=k+1;
     sum:=a[i]+sum;
    end;
  end;
end;

sr:=sum/k;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота