хомяк2005
28.01.2023 16:33

Напишите программный код, используя операторы цикла. Задача: Пользователь с клавиатуры вводит целое число. Найдите сумму всех нечетных чисел.

И постройте трассировочную таблицу

!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
НуриманН
21.11.2020 02:19

использовать Чертежник

алг

нач

цел в, г

вывод "Введите количество повторов по вертикали: "

ввод в

вывод "Введите количество повторов по горизонтали: "

ввод г

нц в раз

нц г раз

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,0)

сместиться на вектор (0,-1)

сместиться на вектор (-1,0)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,1)

сместиться на вектор (1,0)

сместиться на вектор (1,-1)

сместиться на вектор (0,-1)

сместиться на вектор (-1,-1)

сместиться на вектор (-1,0)

сместиться на вектор (-1,1)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (2,2)

сместиться на вектор (1,0)

сместиться на вектор (2,-2)

сместиться на вектор (0,-1)

сместиться на вектор (-2,-2)

сместиться на вектор (-1,0)

сместиться на вектор (-2,2)

поднять перо

сместиться на вектор (5,0)

кц

сместиться на вектор (-(г*3),-3)

кц

кон

Объяснение:

картинка


3. Составьте программу рисования узора, показанного на рисунке. Количество повторений элементов узор
0,0(0 оценок)
Ответ:
лиза2713
22.12.2021 07:30
Python

n = int(input())

s = []

result = [0,0,0]

for i in range(n):

   k = int(input())

   while not (-10000 < k < 10000):

       k = int(input("Out of range. Repeat: "))

   s.append(k)

for i in s:

   if i > 0:

       result[0] += 1

   elif i < 0:

       result[1] += 1

   elif i == 0:

       result[2] += 1

for i in result:

   print(i, end=" ")

Ввод/Вывод:

5                                                                                                                                

3                                                                                                                                

4                                                                                                                                

-4                                                                                                                              

-2                                                                                                                              

0                                                                                                                                

2 2 1

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота