18000000
11.05.2022 01:52

Как составить программу подсчета количеству делений введённого числа на 12 пока оно не станет меньше 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yuliasitnikova
18.06.2020 07:40
Pascal:
var count:integer;
     n:real; 
begin
  write ('N = ');
  readln(n);
  count:=0;
  while n>=10 do
    begin
      n:=n/12;
      inc(count);
    end;
  write ('Kol-vo: ',count);
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
   float n;
   int count = 0;
   cout <<"N = ";
   cin >>n;
   while (n>=10)
   {
      n/=12;
      ++count; 
   }
  cout <<"Kol-vo: " <<count <<endl;
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота