sasharaiskaja
28.09.2020 22:50

Составить блок-схему алгоритма и программу на Паскале. В квадратной комнате шириной A и высотой B есть окно и дверь с размерами C на D и M на N соответственно. Вычислите площадь стен для оклеивания их обоями.
В отчет включить блок-схему алгоритма, текст программы, результат работы кода в виде скриншота окна программы с кодом и полученным результатом. Входные данные задать самостоятельно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
14света14
06.08.2020 21:13
1. Ряд строится по принципу золотого сечения. Формула для вычисления члена последовательности такая:
x(2)=x(1)+1,
x(3)=x(2)+2,
...
x(n)=x(n-1)+n-1

В нашем алгоритме для вычисления следующего члена последовательности будем запоминать текущий член последовательности в переменной kp.
Затем получаем очередной член последовательности суммируя kp и переменную цикла i - 1. Делаем вычисления, выводим на экран и переписываем переменную kp  новым значением.
 
var i,k,kp:integer;
begin
kp:=1;
for i:=1 to 10 do begin
  k:=kp+i-1;
  kp:=k;
  writeln(k:5, k*k:6, k*k*k:8);
  end;
end.
0,0(0 оценок)
Ответ:
begimay2
06.08.2020 21:13
1. Ряд строится по принципу золотого сечения. Формула для вычисления члена последовательности такая:
x(2)=x(1)+1,
x(3)=x(2)+2,
...
x(n)=x(n-1)+n-1

В нашем алгоритме для вычисления следующего члена последовательности будем запоминать текущий член последовательности в переменной kp.
Затем получаем очередной член последовательности суммируя kp и переменную цикла i - 1. Делаем вычисления, выводим на экран и переписываем переменную kp  новым значением.
 
var i,k,kp:integer;
begin
kp:=1;
for i:=1 to 10 do begin
  k:=kp+i-1;
  kp:=k;
  writeln(k:5, k*k:6, k*k*k:8);
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота