Ersultan19
15.06.2021 01:58

python
Дан массив из N элементов. Найти среднее арифметическое всех элементов,
округленное в меньшую сторону.
Формат входных данных
В первой строке N (0 массива.
Формат выходных данных
Среднее арифметическое.
Пример
Входные данные Выходные данные
3
100 200 300
200

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dilnaramusaeva
27.01.2023 10:58

--- Python 3.8.3 ---

#1 - file mdir.py

import os  

import sys  

import difflib

__all__ = ['CreateEmptyDir', 'RmDir']

__here__ = os.path.dirname(os.path.realpath(__file__))

#Функция, создающая папки

def CreateEmptyDir(count, path = __here__):

   try:

       for i in range(count):

           rpath = path + f'\\dir_{i}'

           os.mkdir(rpath)

   except OSError:

       print(f'Failed to create directory {path}')

#Функция, удаляющая папки

def RmDir(mask, path = __here__):

   try:

       for folder in os.listdir(path):

           s = difflib.SequenceMatcher(None, mask, folder)

           if s.ratio() > 0.8:

               f = path + '\\' + folder

               if os.path.isdir(f):

                   os.rmdir(f)

   except OSError as e:

       print(f'Failed to remove directory {f}\n{e}')

#Вызов функций из модуля

def main():

   CreateEmptyDir(10)

   next = input()

   RmDir('dir_')

if __name__ == "__main__":

   main()

#2 - file randchoise.py

import random  

__all__ = ['RandChoise']

def RandChoise(lst):

   if len(lst) == 0: return None  

   return random.choice(lst)

def main():

   data = [1,2,3,4]

   print(RandChoise(data))

if __name__ == "__main__":

   main()

#3 main.py

from mdir import *

from randchoise import *

import time

def main():

   CreateEmptyDir(10)

   time.sleep(3)  #Что бы успели прогрузиться созданные папки

   RmDir('dir_')

   print(RandChoise([1,2,3,4,5,6,7,8,9,2,1,32,31,2540]))

if __name__ == "__main__":

   main()

0,0(0 оценок)
Ответ:
Vikamurzikk
27.01.2023 10:58
Треугольник существует, если сумма длин двух любых его сторон больше длины третьей стороны.
Длина стороны может быть определена как расстояние между соответствующими сторонами треугольника:
\displaystyle L_{AB}=\sqrt{(x_B-x_A)^2+(y_B-y_A)^2

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
type
  Point=record
  x,y:real
  end;

procedure GetPoint(c:char;var M:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Read(M.x,M.y)
end;

function Dist(a,b:Point):=sqrt(sqr(b.x-a.x)+sqr(b.y-a.y));

begin
  var A,B,C:Point;
  GetPoint('A',A); GetPoint('B',B); GetPoint('C',C);
  var ab:=Dist(A,B);
  var bc:=Dist(B,C);
  var ac:=Dist(A,C);
  if (ab<bc+ac) and (bc<ab+ac) and (ac<ab+bc) then
    Writeln('Треугольник существует')
  else Writeln('Треугольник не существует')
end.

Тестовое решение:
Введите координаты точки A: -6.9 -5.3
Введите координаты точки B: 0 11.4
Введите координаты точки C: 9 3
Треугольник существует
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота