SkipMe
21.04.2023 09:34

Задание 1: Составь программу.

Валентина над нерадивой ученицей и попросил ее на уроке перечислить все положительные делители некоторых целых чисел. С маленькими числами она быстро справилась, но большими проблема ученице, составьте программу, которая будет запрашивать любые целые числа и выводить все положительные делители этого числа.

Подсказка: Ввод чисел осуществляется до тех пор, пока не будет введено число 0.

Пример: для числа 10 делители: 1, 2, 5, 10

Задание 2:

Составь программу.

Спортсмен-лыжник начал тренировки, пробежав в первый день 10 км. Каждый следующий день он увеличивал длину пробега на К км больше чем в предыдущий день (К –целое число, 0 < К < 100). Необходимо определить, после какого дня общий суммарный пробег лыжника за все дни превысит М км (М –целое число, 0 < М < 100).

Подсказка: Вывести найденное количество дней K.

Пример: если К=5, М=50, ответ: 8 дней
Язык программирования : Python​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
jdjenud
07.06.2023 10:35
Немного теории в приложении, чтоб не надо было обьяснять ответы

1. В зависимости от изображения чисел системы счисления делятся на:
б. Арабские и римские;

2. Двоичная система счисления имеет основание:
б. 2;

3. Для представления чисел в шестнадцатеричной системе счисления используются:
с. цифры 0-9 и буквы A-F.

4. В какой системе счисления может быть записано число 402?
с. в пятеричной
Есть цифра 4 которой нет в 4ричной и менее

5. Чему равно число DXXVI в десятичной системе счисления?
а. 526;

6. Запись вида 352:
с. Отсутствует в двоичной системе счисления;

7. Какие цифры используются в шестеричной системе счисления?
а. 0,1,2,5;
От 0 до 5

8. какое минимальное основание должна иметь система счисления, если в ней можно записать числа: 401, 122, 232, 111;
а. 5;

9. Какое число записано некорректно?
с. 1212 в двоичной;

10. система счисления-это...?
 символический метод записи чисел

11. Что такое основание системы счисления?
Некое положительное число   1 которое определяет шаг разрядности

12. Позиционной системой счисления называют...
Система счисления где позиция имеет значение

13. Какое минимальное основание может иметь система счисления, если в ней записано число 235?
6

14. Запишите число 254 с римских цифр
CCLIV

15. Чему равно число XCII в десятичной системе счисления?
92

16. Запишите значения цифр A и E в 16-ричной системе счисления:...
А=10 Е=14

17. Переведите числа в десятичную систему счисления:
а. 1011011 ( в 2-ой системой счисления) = 91
б. 3421( в 5-ой системе счисления) = 486

18. Выполните действия:
а) 11011110(в 2-ой системе счисления)
 + 11010010(в 2-ой системе счисления);
 =110110000
в) 87АС(в 16-ричной системе счисления)
 - 2D6F(в 16-ричной системе счисления);
 = 5A3D
б) 20119(в троичной системе счисления)-  1012(в троичной системе счисления); - тут опечатка
г) 1101011 ( в двоичной системе счисления) * 1101 ( в двоичной системе счисления) = 10101101111

19. Переведите число 433 (в десятичной системе счисления) в двоичную, восьмеричную, шестнадцатеричную системы счисления:
110110001_2
661_8
1B1_16

20. вычислите сумму чисел 10(в 2-ой) + 10 (в 8-ой) + 10 (в 10-ой) + 10 (в 16-ой). Представить результат в двоичной системе счисления
2 + 8 + 10 + 16 = 26_10 = 1000110_2

21. В какой системе счисления будет верным равенство 4+4= 10 ?...
8

22. В какой системе счисления: а) 144(в 10-ой) записывается как 100;
144 = 12*12 значит основание 12
б) 98( в 10-ой) записывается как 200;
98 = 2*7*7 значит 7ричная
в) 48(в 10-ой) записывается как 300.
48 = 3*4*4 значит 4ричная
0,0(0 оценок)
Ответ:
nikitanosach2901
17.10.2022 21:43

var s:string;    d1,m1,g1,d2,m2,g2,t,c:integer;    p:boolean;    k:byte;begin

k:=0;

writeln('Введите дату в формате дд.мм.гг');readln(s); val(copy(s,7,2),t,c);{преобразуем год в число}if (c<>0)or(t<0) then k:=1 else g1:=t;{определим високосный год или нет}if (((g1+2000) mod 100<>0)and((g1+2000) mod 4=0))or((g1+2000) mod 400=0) then p:=trueelse p:=false;

val(copy(s,4,2),t,c);if (c<>0)or not(t in [1..12]) then k:=1 else m1:=t;

val(copy(s,1,2),t,c);if (c<>0)or((m1 in [1,3,5,7,8,10,12])and not(t in [1..31]))         or((m1 in [4,6,9,11])and not(t in [1..30]))         or(p and(m1=2)and not(t in [1..29]))         or(not p and(m1=2)and not(t in [1..28]))then k:=1 else d1:=t;if k=1 thenbeginwriteln('Дата введена неверно!');endelsebeginif(m1=1)and(d1=1)then begin  d2:=31;  m2:=12;  g2:=g1-1; end

else if ((m1 in [5,7,10,12]) and(d1=1))then begin  d2:=30;  m2:=m1-1;  g2:=g1; end

else if ((m1 in [2,4,6,8,9,11]) and(d1=1))then begin  d2:=31;  m2:=m1-1;  g2:=g1; end

else if(m1=3)and (d1=1) then begin  if p then d2:=29 else d2:=28;  m2:=m1-1;  g2:=g1; end

else begin  d2:=d1-1;  m2:=m1;  g2:=g1; end;writeln('Предыдущая дата:');if d2<10 then write('0',d2,'.')else write(d2,'.');if m2<10 then write('0',m2,'.')else write(m2,'.');write(g2);end;end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота