Vladikot77
20.04.2022 07:46

Нужно написать программу, используя только цикл "While" Найти сумму четных цифр числа
Составить таблицу значений функции y = 5 - x2/2 на отрезке [-5; 5] с шагом 0,5.
Написать программу, подсчитывающую количество четных и нечетных цифр в числе.
Сумма и произведение цифр числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yurasokolov232
16.03.2022 03:31
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var n:=ReadInteger('Количество элементов=');
  var b:=ArrRandomReal(n,-10,20);
  b.Println(', ');
  var mx:=b.Max;
  var c:=b.Where(x->x<>mx);
  c.Println(', ')
end.

Тестовое решение:
Количество элементов= 13
-3.19967562016085, 0.998729616868649, 17.2918094030078, 1.10658910642685, 10.4760369241592, 6.72070787601206, 8.34657945593194, 12.5555840984711, 13.4678390079494, -1.30778588881147, 19.5660732731065, 18.4909354934892, 9.13206894841607
-3.19967562016085, 0.998729616868649, 17.2918094030078, 1.10658910642685, 10.4760369241592, 6.72070787601206, 8.34657945593194, 12.5555840984711, 13.4678390079494, -1.30778588881147, 18.4909354934892, 9.13206894841607
0,0(0 оценок)
Ответ:
vanya33251243
02.03.2021 09:11
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqIntegerWhile(x->x<=100).ToArray;
  Writeln('Количество четных чисел равно ',a.Where(x->x.IsEven).Count);
  a.Transform(x->x.IsOdd?x*x:x); a.Println
end.

Пример
35 24 38 83 110
Количество четных чисел равно 2
1225 24 38 6889

begin
  Writeln('S=',ReadSeqIntegerWhile(x->x>=0).Select(x->x mod 10).Sum)
end.

Пример
16 24 19 21 45 0 23 -21
S=28

begin
  var n:=ReadInteger('n=');
  var St:=new Stack <integer>;
  while n>0 do begin
    St.Push(n mod 10);
    n:=n div 10
    end;
  var a:=St.ToArray;
  a.Println(',');
  Writeln('Сумма цифр: ',a.Sum);
  Writeln('Сумма нечетных цифр: ',a.Where(x->x.IsOdd).Sum);
  Writeln('Сумма старшего и младшего разрядов: ',a.First+a.Last);
end.

Пример
n= 53214212
5,3,2,1,4,2,1,2
Сумма цифр: 20
Сумма нечетных цифр: 10
Сумма старшего и младшего разрядов: 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота