tanya732
31.12.2020 07:55

Написать программу :Если Х принадлежит отрезку [-2,5], то вывести сообщение "X принадлежит", Если Х не принадлежит отрезку [-2,5], то вывести сообщение "X принадлежит"(использовать логические операции)​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ВоржеваСоня
01.02.2022 09:01
Var  i: integer;  begin
for i:=1 to 9 do  write(i);  writeln(10);
for i:=0 to 8 do  write(i);  writeln(9);
for i:=1 to 2 do  write('0');  for i:=1 to 7 do  write(i);  writeln('8');
for i:=1 to 3 do  write('0');  for i:=1 to 6 do  write(i);  writeln('7');
for i:=1 to 4 do  write('0');  for i:=1 to 5 do  write(i);  writeln('6');
for i:=1 to 5 do  write('0');  for i:=1 to 4 do  write(i);  writeln(5);
for i:=1 to 6 do  write('0');  for i:=1 to 3 do   write(i);  writeln('4');
for i:=1 to 7 do  write('0');  for i:=1 to 2 do  write(i);  writeln(3);
for i:=1 to 8 do  write('0');  write('1');writeln('2');
for i:=1 to 9 do  write('0');  writeln(1);  
end.

Как сделать более кратко не знаю. Но эта программа работает.
0,0(0 оценок)
Ответ:
madik0721
01.02.2022 09:01
Const
  nn = 20;

var
  i, j, n: integer;
  a: array[1..nn, 1..nn] of integer;

begin
  writeln('Задайте размер матрицы n');
  readln(n);
  if n > nn then
    writeln('Вы превысили допустимый размер матрицы 20')
  else begin
    writeln('Матрица-результат');
    for i := 1 to n do
    begin
      writeln;
      for j := 1 to n do begin
        if i < j then a[i, j] := 1
        else if i = j then a[i, j] := 2
        else a[i, j] := 3;
        write(a[i, j]:2)
      end;
    end;
    writeln
  end
end.

Тестовый пример:

Задайте размер матрицы n
10
Матрица-результат

 2 1 1 1 1 1 1 1 1 1
 3 2 1 1 1 1 1 1 1 1
 3 3 2 1 1 1 1 1 1 1
 3 3 3 2 1 1 1 1 1 1
 3 3 3 3 2 1 1 1 1 1
 3 3 3 3 3 2 1 1 1 1
 3 3 3 3 3 3 2 1 1 1
 3 3 3 3 3 3 3 2 1 1
 3 3 3 3 3 3 3 3 2 1
 3 3 3 3 3 3 3 3 3 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота