mohammadroshann
21.09.2022 07:13

Программирование арифметических операций на языке Ассемблер Составить программу на языке ассемблер для микропроцессора Intel 8080, вычисляющую значение функции Y. Соблюдение указанного приоритета операций обязательно.

Выбрать произвольно адреса ячеек памяти (в пределах адресуемого Intel 8080 пространства) для хранения значений аргументов и значения функции. Составить программу и отладить её в эмуляторе Intel 8080.
Y=x1–(x2+x3–x4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MarinaKim111
24.07.2022 21:30
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a,b,c:real;
  Read(a,b,c); // не вводить одинаковых!
  if a>b then
    if a>c then // a > [b,c]
      if b>c then Writeln('Среднее - второе число')
      else Writeln('Среднее - третье число')
    else Writeln('Среднее - первое число')
  else
    if b>c then // b > [a,c]
      if a>c then Writeln('Среднее - первое число')
      else Writeln('Среднее - третье число')
    else Writeln('Среднее -  второе число')
end.
0,0(0 оценок)
Ответ:
малина106
24.07.2022 21:30
По моему так:
program p;
var
a,b,c:integer;
begin
writeln('первое число:');
readln(a);
writeln('второе число:');
readln(b);
writeln('третие число:');
readln(c);
if (a>b) and (a>c) then
writeln('Первое число является наибольшим');
if (a>b) and (a<c) or (a<b) and (a>c) then
writeln('Первое число является средним');
if (a<b) and (a<c) then
writeln('Первое число является наимешим');
if (b>a) and (b>c) then
writeln('Второе число является наибольшим');
if (b>a) and (b<c) or (b<a) and (b>c) then
writeln('Второе число является средним');
if (b<a) and (b<c) then
writeln('Второе число является наимешим');
if (c>b) and (c>a) then
writeln('Третие число является наибольшим');
if (c>b) and (c<a) or (c<b) and (c>a) then
writeln('Третие число является средним');
if (c<b) and (c<a) then
writeln('Третие число является наимешим');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота