Составить программу. Известен рост трех человек. Определить, одинаков ли их рост. Составить программу, которая уменьшает первое введенное число в два раза, если оно больше второго введенного числа по абсолютной величине.
1. Не знаю. Вопрос точно правильно написан? 2. в.пиксель 3. а.красный, синий, зеленый 4. а.хранения информации о цвете каждого пикселя экрана монитора 5. г.программа для создания и редактирования рисунков 6. б.графических примитивов 7.б. растровой графики 8. а.электронное устройство для хранения двоичного кода изображения, выводимого на экран 9. а.дисплейный процессор и видеопамять(немного есть сомнения) 10. в. bmp 11.Разрешающая сканера 300 dpi (dot per inch - точек на дюйм) означает, что на отрезке длиной 1 дюйм сканер различить 300 точек. Переведем разрешающую сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр: 300dpi : 2,54 ≈ 118 точек/см. Следовательно, размер изображения в точках составит 25*118 и 30*118 = 2950х3540 Общее количество точек изображения равно: 2950 * 3540 = 10 443 000. Информационный объем файла равен: 3 байта= 24 бита. 24 * 10 443 000 = 250632000 бит = 31329000 байт = 30595 Кб ≈ 30 Мб 12.65536 означает, что на каждый пиксель отводится два байта. Итого имеем 1280*2КБ=2,5МБ.
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016 function Avg(a:array[,] of integer):real; begin var s:=0; var k:=0; foreach var e:integer in a do if e>0 then begin s+=e; Inc(k) end; if k>0 then Result:=s/k else Result:=1e-100; end;
begin var A:=MatrixRandom(4,4,-50,50); Writeln(A); Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3); var B:=MatrixRandom(5,5,-30,30); Writeln(B); Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3); var C:=MatrixRandom(4,5,-25,38); Writeln(C); Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3); end.
Тестовое решение: [[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]] Среднее арифметическое положительных равно 24.000 [[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]] Среднее арифметическое положительных равно 15.083 [[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]] Среднее арифметическое положительных равно 19.200
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку