zhikinemil26
25.02.2021 16:34

Pascal Ниже записан алгоритм. Сколько существует таких чисел `x`, при вводе которых алгоритм печатает сначала `6`, а потом `27`? Что делает данная программа? Какие это числа? Объясните свои ответы.
var x, a, b: longint;
begin
readln(x);
a:=0; b:=1;
while x>0 do begin
a:=a + 1;
if a mod 2 =0 then
b:=b*(x mod 10);
x:=x div 10;
end;
writeln(a); write(b);
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dayana2005041
06.04.2021 16:33

а не проще на типе интеджер

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота