angel496
09.08.2020 00:25

Есептерді Python тілінде жазыңыз:
5+98*2

27/5-3+14

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Reixerrr
16.07.2020 15:28
Исходное число 665675757
1)665675757:2=332837878 и в остатке 1
значит пишем 1
2)332837878:2=166418939 и в остатке 0
значит пишем 0
3)166418939:2=83209469 и в остатке 1
значит пишем 1
4)83209469:2=41604734 и в остатке 1
значит пишем 1
5)41604734:2=20802367 и в остатке 0
значит пишем 0
6)20802367:2=10401183 и в остатке 1
значит пишем 1
7)10401183:2=5200591 и в остатке 1
значит пишем 1
8)5200591:2=2600295 и в остатке 1
значит пишем 1
9)2600295:2=1300147 и в ост 1
зн пишем 1
10)1300147:2=650073 и в ост 1
зн пишем 1
11)650073:2=325036 и в ост 1
зн пишем 1
12)325036:2=162518 и в ост 0
зн  пишем 0
13)162518:2=81259 и в ост 0
зн пишем 0
14)81259:2=40629 и в ост 1
зн пишем 1
15)40629:2=20314 и в ост 1
зн пишем 1
16)20314:2=10157 и в ост 0
зн пишем 0
17)10157:2=5078 и в ост 1
зн пишем 1
18)5078:2=2539 и в ост 0
зн пишем 0
19)2539:2=1269 и в ост 1
зн пишем 1
20)1269:2=634 и в ост 1
зн пишем 1
21)634:2=317 и в ост 0
зн  пишем 0
22)317:2=158 и ост 1
зн пишем 1
23)158:2=79 и ост 0
зн пишем 0
24)79:2=39 и ост 1
зн пишем 1
25)39:2=19 и ост 1
зн пишем 1
26)19:2=9 и ост 1
зн пишем 1
27)9:2=4 и ост 1
зн пишем 1
28)4:2=2 и ост 0
зн пишем 0
29)2:2=1 и ост 0
зн пишем 0
30)1:2=0 и ост 1
зн пишем 1
число в двоичной системе 10110111110011010110101111001
0,0(0 оценок)
Ответ:
ViShEnKalкрасная
18.02.2020 15:21

//Для проверки результата вывел массив на экран

using System;

namespace App1

{

   class Program

   {

       private static void Main()

       {

           const int x = -10;

           const int y = 20;

           int n, k;

           Console.Write("Enter n: "); n = int.Parse(Console.ReadLine());

           Console.Write("Enter k: "); k = int.Parse(Console.ReadLine());

           Console.WriteLine($"{Environment.NewLine}Array:");

           int counter = 0;

           int[] array = new int[n];

           Random rand = new Random();

           for (int i = 0; i < array.Length; i++)

           {

               array[i] = rand.Next(x, y + 1);

               if (array[i] > 0 && array[i] % k == 0) { counter++; }

               Console.WriteLine($"{i + 1}. {array[i]}");

           }

           Console.Write(Environment.NewLine);

           if (counter > 0) { Console.WriteLine($"В массиве {counter} элементов, соответствующих заданному условию."); }

           else { Console.WriteLine("В массиве нет элементов, соответствующих заданному условию."); }

           Console.ReadKey();

       }

   }

}


Написать программу для массива ( c# ): п1. дан массив целых чисел из n элементов, заполненный случай
Написать программу для массива ( c# ): п1. дан массив целых чисел из n элементов, заполненный случай
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота