Gakaka
06.03.2021 07:03

Написать программу на языке паскаль. вводятся размер и элементы одномерного массива a(n), состоящего из целых чисел. подсчитать сумму простых чисел, оканчивающихся на 3. результат вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
INKOGNIT009
17.06.2020 22:33

uses crt;
Var a:array [1..100] of integer; i,n,s: integer;
Begin

Writeln('Введите размер массива'); readln(n);

For i:=1 to n do begin
                    writeln('Введите элемент массива номер  ',i); read(a[i]);
                 end;

For i:=1 to n do
    if a[i] mod 10=3 then s:=s+a[i];
    
Writeln('Сумма = ',s);

end.

 

Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;"

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота