anna228po
20.08.2020 13:30

2. Запишите программный код к задаче. Дано вещественное число A и целое число N (>0).Составьте программу, которая выводит все целые степени числа A от 1 до N.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
9000Кира0009
04.03.2021 06:00

С++

#include <iostream>  

using namespace std;

int main()

{

   int A;  //Вводим число А целого типа

   int N;  //Вводим число N целого типа

   cin>>A>>N;  //Вводим значения чисел с клавиатуры

   for(int i = 1; i<=N; ++i)  //Выполняем цикл от 1 до числа N

   {

       for(int j = 1; j<i; ++j)  //Выполняем цикл от 1 до i

           A*=A;  //Умножаем число А на самого себя по определению степени

       cout<<A<<endl; //Выводим число А

   }

   return 0;  

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота